[PlanetCCRMA] valid port for jackrec ?

David Slimp rock808@gmail.com
Thu Feb 16 16:31:01 2006

HA!    Thanks. :)
I think I tried just about EVERY other binary in that package other
than that one!

However, now it's failing due to overruns, and telling me to pick
a bigger buffer (which I now have tried up to "-B 128000").

Actually, all I want to do is record about 6 hours of spoken word
audio in a low format (8bit, mono, 22050Hz) so it doesn't take
up a lot of disk space.

Perhaps there is a better tool?  -- since I don't see a way to set
jackrec to record at those given levels... I suppose I may try
those settings in qjackctl and see if that gets me the same thing,
but, STILL having the overrun problem.


On 2/16/06, Fernando Lopez-Lezcano <nando@ccrma.stanford.edu> wrote:
> On Thu, 2006-02-16 at 18:10 -0600, David Slimp wrote:
> > I'm trying to record some input on my Delta 1010LT using jackrec,
> > but it needs a "port".
> >
> > There are no docs, and google doesn't turn up anything either.
> >
> > I've tried:  output1 output_1, playback_1, 1, in1, in_1, capture_1
> >
> > When I run qjackctl, I see input/output connection ports such as
> > capture_1, playback_1
> > capture_2, playback_2
> > etc
> "jack_lsp", part of the jack-audio-connection-kit-example-clients
> package, will list the ports for you. You will/should see something
> like:
> > jack_lsp
> alsa_pcm:capture_1
> alsa_pcm:capture_2
> alsa_pcm:playback_1
> alsa_pcm:playback_2
> alsa_pcm:playback_3
> alsa_pcm:playback_4
> alsa_pcm:playback_5
> alsa_pcm:playback_6
> Those are the ports...
> -- Fernando

David Slimp

"On proprietary platforms, eventually you'll run into 'you can't do that.'
 On open platforms, you'll run into 'you have to learn more to do that.' "
 -- Ian Smith-Heisters