[PlanetCCRMA] VST on Fedora Core 4?

Shayne O'Connor forums@machinehasnoagenda.com
Sun Feb 12 06:48:01 2006

Timo Sivula wrote:
> Hello,
> I just recently upgraded from FC1 to FC4. I have to HDD:s on my PC, one
> used to run FC1 but is now FC4. The other is still using FC3. The edge
> kernel works fine and Fedora Core 4 seems nice.
> However, I have trouble getting my VSTs working right. After the
> upgrade, jack_fst compiled under FC1 still starts nicely and loads my
> B4.DLL without problems. B4 can be played, but giving it any kind of
> program change messages either from my keyboard or Rosegarden crashes
> it. I tried to start from scratch according to my FC3 VST howto:
> http://www.geocities.com/dn_liitto/english/VST-on-FC3-Planet-CCRMA-HOWTO.html
> I get stuck when trying to compile the fst library:
> ..................
> [04:27 PM] el:/usr/local/src/fst-1.6$ make
> make[1]: Entering directory `/usr/local/src/fst-1.6/fst'
> LD_LIBRARY_PATH=":$LD_LIBRARY_PATH" /usr/bin/winebuild -fPIC -o
> libfst.spec.c --exe libfst -mgui   pthread.o interlocked.o gettid.o
> libwinelib.o vstwin.o fstinfofile.o fst.o   -L/usr/lib/wine
> -L/usr/lib/wine  -ladvapi32 -lcomdlg32 -lgdi32 -lkernel32 -lodbc32
> -lole32 -loleaut32 -lshell32 -luser32 -lwinspool
> winebuild: executable must be named via the -F option
> make[1]: *** [libfst.spec.c] Error 1
> make[1]: Leaving directory `/usr/local/src/fst-1.6/fst'
> make: *** [fst] Error 2
> [04:27 PM] el:/usr/local/src/fst-1.6$
> ....................
> Has anyone tried my VST howto on FC4 and had success? Any ideas what
> might be wrong here. I would appreciate any help to upgrade the HOWTO to
> FC4.

this from a dave phillips post to LAU:

> Recently WINE
> has altered some syntax and flags for some of its utilities, including
> the winebuild binary. The dssi-vst and libfst stuff (including jack_fst)
> use winebuild in the final stages of the build, and they failed because
> a flag is missing. The fix is to add the -F flag after the --exe
> directive in the appropriate Makefiles. It's only three or four
> instances, and after making the changes the builds proceeded without
> problems. 

there's always xfst, which should compile with any version of wine.

btw - has anyone managed to get dssi-vst to compile against wine 0.96?
it complains of --debug option for me.