[PlanetCCRMA] Ingo kernels

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Sat Dec 9 11:13:02 2006

On Fri, 2006-12-08 at 22:29 -0500, blindman jones wrote:
> On 12/7/06, Fernando Lopez-Lezcano <nando@ccrma.stanford.edu> wrote:
> > On Thu, 2006-12-07 at 12:42 -0500, Gregory Maxwell wrote:
> > > Is anyone here using the Ingo Molnar RT kernel RPMS?
> > >
> > > http://people.redhat.com/mingo/realtime-preempt/yum.README
> >
> > I'm building my new kernels based on them. I have tried -rt6 with much
> > better results than his previous versions[*] and I'm compiling -rt8 as I
> > type. I'm getting close to releasing something on Planet CCRMA...
> >
> > The kernels are now named kernel-rt-* so that the problems with
> > installing older packages are over (that is hardwired in yum with no
> > easy override).
> >
> > You could obviously try them, it would be nice to hear other user
> > experiences with them.
> kernel-rt-2.6.19-1.rt10.0001.i686.rpm:
> Ok, I have a Asus P4PE motherboard+ P4 2.54Ghz and a 1010LT audio card
> and I have not been able to get any rtt kernels to boot for me, I
> always used the planetccrma rdt kernels with good results. There are
> two kernels at the mingo link above, a rt10 & and a rt8... I installed
> the yum file and only the rt10 showed up in yum, so I installed that.
> It hung where all the rtt kernels have before "Starting udev:" then
> nothing. I tried adding acpi=off and it booted. Warm feelings were
> lost when I started Qjackctl and the output screen showed xruns
> streaming past till the whole thing crashed and vanished. Qjackctl
> restarted, I changed the Frames/Period from 256 to 512, same thing...
> streaming xruns then crash. I changed from 512 to 1024 and periods to
> 3 and it is up with a few xruns then quiet... That allowed me to fire
> up JAMin/Ardour but the audio output pops and stutters.

Hmmm, too bad. 
I presume you are running Jack with realtime priority, right? In fc6
(for now) you need to manually tweak /etc/security/limits.conf to allow
normal users to access SCHED_FIFO (see my posting with the first
announcement of packages for fc6). For best performance you also would
need to have the rtirq script (you could use the one from fc5 for now)
but I doubt that's the problem in this case. 

What if you boot without the graphical front end? (ie: edit the grub
kernel line and remove the "rhgb quiet" part at the end). 

> kernel-rt-2.6.19-1.rt8.0001.i686.rpm:
> Same results
> Fernando:
> I kept the rt8 installed and will gladly reboot it and supply the
> output of anything you think will help you... just let me know what
> you need and I will pass it along.
> oh, and booting them without acpi=off shows this:
> irq 20: nobody cared (try booting with the "irqpoll" option)
> handlers:
> [<f909bdba>] (ahca_linux_isr+0x0/0x1a7 [aic7xxx])

Hmmm, are you booting from a scsi disk?
-- Fernando

> turning off IO-APIC fast mode.
> Starting udev:
> then it hangs.
> later,
> mjr
> >
> > [*] but the smp machine I was using to test previous versions died over
> > the weekend and I don't have a replacement yet, so I'm not sure if the
> > performance is better or if the problems I was having with xruns were a
> > result of running smp
> >
> > -- Fernando
> >
> >
> > _______________________________________________
> > PlanetCCRMA mailing list
> > PlanetCCRMA@ccrma.stanford.edu
> > http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma
> >