[PlanetCCRMA] Ingo kernels

blindman jones erleichda@gmail.com
Fri Dec 8 19:30:04 2006

On 12/7/06, Fernando Lopez-Lezcano <nando@ccrma.stanford.edu> wrote:
> On Thu, 2006-12-07 at 12:42 -0500, Gregory Maxwell wrote:
> > Is anyone here using the Ingo Molnar RT kernel RPMS?
> >
> > http://people.redhat.com/mingo/realtime-preempt/yum.README
> I'm building my new kernels based on them. I have tried -rt6 with much
> better results than his previous versions[*] and I'm compiling -rt8 as I
> type. I'm getting close to releasing something on Planet CCRMA...
> The kernels are now named kernel-rt-* so that the problems with
> installing older packages are over (that is hardwired in yum with no
> easy override).
> You could obviously try them, it would be nice to hear other user
> experiences with them.

Ok, I have a Asus P4PE motherboard+ P4 2.54Ghz and a 1010LT audio card
and I have not been able to get any rtt kernels to boot for me, I
always used the planetccrma rdt kernels with good results. There are
two kernels at the mingo link above, a rt10 & and a rt8... I installed
the yum file and only the rt10 showed up in yum, so I installed that.
It hung where all the rtt kernels have before "Starting udev:" then
nothing. I tried adding acpi=off and it booted. Warm feelings were
lost when I started Qjackctl and the output screen showed xruns
streaming past till the whole thing crashed and vanished. Qjackctl
restarted, I changed the Frames/Period from 256 to 512, same thing...
streaming xruns then crash. I changed from 512 to 1024 and periods to
3 and it is up with a few xruns then quiet... That allowed me to fire
up JAMin/Ardour but the audio output pops and stutters.

Same results

I kept the rt8 installed and will gladly reboot it and supply the
output of anything you think will help you... just let me know what
you need and I will pass it along.

oh, and booting them without acpi=off shows this:

irq 20: nobody cared (try booting with the "irqpoll" option)
[<f909bdba>] (ahca_linux_isr+0x0/0x1a7 [aic7xxx])
turning off IO-APIC fast mode.
Starting udev:

then it hangs.


> [*] but the smp machine I was using to test previous versions died over
> the weekend and I don't have a replacement yet, so I'm not sure if the
> performance is better or if the problems I was having with xruns were a
> result of running smp
> -- Fernando
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA@ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma

michael jones * erleichda archiving * usa
shivering is the first step towards your destiny.....