[PlanetCCRMA] Newbie needs help - Jack

Roy Vestal rvestal@trilug.org
Tue Aug 8 13:13:01 2006

Well, I sent this to Fernando and for forgot to CC: the group.

Found the problem. I booted into the "stock" FC3 kernel and tried 
running Jack. When that failed as a normal user, I ran it as root via 
sudo. Since Ardour wouldn't work properly, i ran it as root via sudo as 
well. This created my .jackrc file and my .ardour directory in my normal 
user /home to be root:root with 755 permissions.

The fix was quite simple, and frankly I feel a little silly. I rebooted 
into the ccrma core kernel and removed the .jackrc file and .ardour 
directory from my normal user /home dir. I restarted qjackctl as my 
normal user and !voila! It worked!

Hope my rushing through the docs helps someone down the road!

His sillyness,

Roy Vestal wrote:
> After I sent my mail, I did some more reading away from the Studio. I 
> don't think I booted into the Core kernel, but the "stock" FC3 kernel. 
> I'm assuming this is my error?  Will try later tonight once I leave my 
> "day" job.
> :)
> Joseph Dell'Orfano wrote:
>> Quick question - did you go through the setup instructions on the
>> PlanetCCRMA site? This walks you through patching the kernel and all
>> that good stuff to make audio work well. I am a former newbie with NO
>> DAW experience when I set up my first linux DAW using the PlanetCCRMA
>> setup. I was able to successfully go through the very well written and
>> explicit instructions successfully.
>> Of course if you did all that, then never mind. I'll leave it as a
>> complement to Fernando, to whom we all owe a great deal...
>> -Joe
>> On Sun, 2006-08-06 at 20:31 -0500, Roy Vestal wrote:
>>> Ok...I'm new to DAW on Linux. I've used Windows and Mac but I'm 
>>> building my own and it's the first I've worked with on Linux.
>>> Here's my setup:
>>> FC3
>>> Delta 1010 (NOT LT) - No other sound card
>>> Ardour
>>> QJackCtl
>>> Now, when a start Jack as a USER (normal user), I get the error: 
>>> "Cannot connect to Jack with client", I'm assuming it's a permissions 
>>> problem, because if I run it as root, it loads and I can connect in's 
>>> to out's and such.
>>> Obviously, Ardour laughed at me when I started it up as USER. When I 
>>> started qjackctl as root and ardour as root and it was still not 
>>> happy. Which is what I was hoping.
>>> The docs for Jack are very vague and not easy to follow.
>>> So my question is, how do I setup jack so a normal user can start the 
>>> daemon and connect using my software?
>>> TIA,
>>> Roy
>>> _______________________________________________
>>> PlanetCCRMA mailing list
>>> PlanetCCRMA@ccrma.stanford.edu
>>> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma
> _______________________________________________
> PlanetCCRMA mailing list
> PlanetCCRMA@ccrma.stanford.edu
> http://ccrma-mail.stanford.edu/mailman/listinfo/planetccrma