[PlanetCCRMA] kernel config problems

Michael Karban mgkarban@optusnet.com.au
Mon Nov 14 20:10:02 2005

Hi all,

I'm a very new panetccrma user, however I've been using linux for 
years.  Just came over from demudi.

So my problem is as such...

I'm trying to get my wacom intuos3 working.  However certain usb code in 
the kernel grabs the tablet before the wacom module can.

The wacom package has replacements for these modules.

This is where things start getting tricky.

In the supplied ccrma kernel ( the required usb/mouse modules 
are built in.  So no rebuilding the modules.  Damn.   So I go to 
recompile the kernel.

I've come across a lot of things that have confused me, so I'm going 
explain what I did, and for my actual questions, I'll just number them.

First things first... My system.
Nothing special here, athlon 2800+ 1 gig ram, nvidia gfx, onboard 
nforce2 sound, and of course, my tablet... ;)

I installed FC3 from the cd's, then set up apt as per ccrma docs.

First time working with src.rpm... ugh...  ok, I'm sure thier fine and 
all, I just need to learn them...

Trying to find the src.rpm for the kernel source wasn't easy.  Couldn't 
find any reference to the source (other than it was available) on the 
website.  Eventually found a link on in this lists archive and 
downloaded it from there.  I would have preferred a repo.

1. What do I need to put in my apt/sources lists to download src from ccrma?

Ok, so I've got the source, and I've worked out how to rebuild it!!  
With the exact same config as before... grrr arg damnit...

Now from what I've read the process is to run the spec files prep 
(rpmbuild -bp etc...) then do my kernel configure, then build it (-bc 
flag).  However when doing the build, it runs the prep again, clobering 
my new config.

2.  Is the prep being run while using the -bc flag improper behaviour?
    What am I doing wrong here?

So forget trying to get a nice shiny rpm for my customer kernel... I've 
got the patched source and .config and I'm doing it manual....

It compiles nicely, boots... But it doesn't have the module I need.

After experimenting a little I find that what is usually code can be 
compiled into a module is being forced into the kernel... I can't even 
turn it off completely.  make menuconfig/xconfig just simply don't let 
me select it.
I tried manually editing the .config.

It reverts my change during the build... wtf?

3.  What is different about the ccrma sources that I can't compile 
MOUSEDEV as a module?

So at this point I am stumped.

4. Is there an easier way to do this that I missed somehow? ;)

Other than that I'm quite enjoying planetccrma.
Big thanks to the devs, everything else on this system is great so far.

PS.  One other question....
Anyone got any good links on setting up fc3 repos for apt?
I've got a couple working as per my googling, however I'm still having 
to drag out yum here and there to get certain things...