[PlanetCCRMA] ALSA/Soundcard problems

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Mon Nov 7 09:52:09 2005

On Sun, 2005-11-06 at 23:17 -0500, Tim Boulette wrote:
> Fernando Lopez-Lezcano wrote:
> >On Sun, 2005-11-06 at 22:48 -0500, Tim Boulette wrote:
> >>Fernando Lopez-Lezcano wrote:
> >>>On Sun, 2005-11-06 at 20:42 -0500, Tim Boulette wrote:
> >>>>Mark Knecht wrote:
> >>>>>On 11/6/05, Tim Boulette <tboulet1@maine.rr.com> wrote:
> >>>>>>I'm a complete newbie to Linux and PlanetCCRMA, so I'm hoping you all can
> >>>>>>bear with me if this is a simple question and I'm just missing it.  I'll
> >>>>>>gladly accept all the help I can get.
> >>>>>>
> >>>>>>I've installed Fedora Core 3 (in fact, I've pretty much followed the
> >>>>>>installation instructions from the Planet CCRMA website (http://ccrma
> >>>>>>stanford.edu/planetccrma/software/installtwosix.html) verbatim.
> >>>>>>
> >>>>>>My soundcard is a M-Audio Delta 66.  (Also have a VIA AC'97 on the mainboard
> >>>>>>which I don't really use.)  The Delta 66 is working fine in WinXP.  During
> >>>>>>FC3 installation, setup seems to identify the card, but when I test it I get
> >>>>>>no sound.
> >>>>>>
> >>>>>>I've proceeded with installation anyway, hoping to fix the problem later,
> >>>>>>but have been unsuccessful so far.  I've tried updating all FC3 components;
> >>>>>>manually installing ALSA; and I've even tried alsaconf to manually set the
> >>>>>>Delta 66 as my card -- all to no avail.
> >>>>>>
> >>>>>>Can anybody give me some ideas about how to solve this problem?
> >>>>>>
> >>>>>>            
> >>>>>>
> >>>>>Folks would like to see your /etc/modprobe.conf file I'm sure. Also
> >>>>>the output of lsmod, and possibly the output of
> >>>>>
> >>>>>cat /proc/asound/cards
> >>>>>
> >>>>>One thing some new folks miss is unmuting the card. Have you ran
> >>>>>alsamixer and made sure that the card has volume up on the master and
> >>>>>PCM cannels? (I'm assuming alsamixer works on that card...)
> >>>>>
> >>>>>          
> >>>>>
> >>>>Here's the output of cat /proc/asound/cards:
> >>>>
> >>>>0 [M66            ]: ICE1712 - M Audio Delta 66
> >>>>                    M Audio Delta 66 at 0xb000, irq 12
> >>>>1 [rev50          ]: VIA686A - VIA 82C686A/B rev50
> >>>>                    VIA 82C686A/B rev50 at 0xa000, irq 12
> >>>>
> >>>>Hmm.  Interesting that the IRQ's are the same--again, they work in 
> >>>>Windows XP.  I've made sure the card isn't muted (in fact, in 
> >>>>frustration I'd turned every slider up full).  Peter, I'm NOT (yet) 
> >>>>using envy24control.  That may be the answer, but (I'm embarassed to 
> >>>>say) I can't figure out how to install it. 
> >>>>        
> >>>>
> >>>It is part of the alsa-tools package, most probably you already have it
> >>>installed ("rpm -q alsa-tools" to find out - "apt-get install
> >>>alsa-tools" to install it). 
> >>>
> >>>If you have it "envy24control" will start it from a terminal. 
> >>>
> >>I'm sorry -- I just realized I hadn't reinstalled the planetccrma 
> >>package in my latest go-round.  Having done that, I now have the 
> >>envy24control mixer running.  Still no sound, though.
> >
> >There is a tab with sliders for the analog outputs, are those up?
> >What is it your are using to test sound output?
> >
> Under the "analog volume" tab, I've moved all sliders to max.  I'm using 
> audio player, playing a .wav file.  When I push the play button, I get 
> the following popup error message:
> "Please check that:
> Your soundcard is configured properly
> You have the correct output plugin selected
> No other program is blocking the soundcard"

So... what output plugin do you have selected?
See if you can start jack, for example, in a terminal do:
   jackd -R -d alsa -d hw
if it starts fine you could start Hydrogen, load a demo sequence and see
if you get sound. 

-- Fernando