[PlanetCCRMA] Network problems in Fedora Core 2 on Thinkpad A21p

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Mon Mar 28 10:56:00 2005

On Mon, 2005-03-28 at 06:13, Roger B. Dannenberg wrote:
> I can't get networking to work (under FC2 from PlanetCCRMA with the default
> FC2 kernel on my Thinkpad A21p).

The default kernel being 2.6.10-2.1.ll? Have you tried with the newer

> The built-in interface is having some
> problems (even under Windows), so I've tried two different PCMCIA network
> cards:
> 	Linksys PCMPC100 EtherFast 10/100
> 	CNET CNF401 100/10
> The Linksys card would work for a bit, but after transferring a few
> megabytes, it would become inactive. I could manually make it active again
> using the System Settings->Network utility, and it would work for another
> few megabytes and go inactive again.

Do you see any messages in /var/log/messages that could be related to
this? Or in the output of the dmesg command?

> The CNET card seems to be recognized as an RTL-8139/8139c/8139c+, but I
> can't get it to work. It does not seem to fail consistently. The furthest it
> has gotten is to request an IP address using DHCP, but the dialog didn't
> complete. I also tried typing in a fixed IP address, and I still can't get a
> connection. It's not clear to me whether FC2 has correctly identified the
> device or whether it is just guessing. There do not seem to be hardware
> compatibility lists for FC2, but I think these are pretty common cards.
> Both cards work fine under WinXP.
> I've been searching the web for clues, but haven't found anything that
> helps. Is there a step-by-step diagnostic procedure? One suggestion was
> install SUSE or some other Linux and see if it works, but that's a little
> drastic, and I'm not sure that would help, given my goal of bringing up
> PlanetCCRMA.

-- Fernando