[PlanetCCRMA] Help on aplay: Access type not available

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Tue Mar 15 10:23:01 2005

On Tue, 2005-03-08 at 03:48, Renato Degli Esposti wrote:
> Hi,
> I'm new to music on linux and I need your help.
> I have two machines with FC3: a small celeron box and my dev
> workstation.
> . I followed instructions on
> http://ccrma.stanford.edu/planetccrma/software/installtwosix.html to
> install on both boxes ccrma on FC3. I've used the first machine to
> record 4 tracks using an MAUDIO Delta44 with ardour. 
> Now I need to play these 4 tracks , one for output. I'm triyng to use
> this command:
> aplay -c4 -d400 -fS16_LE -twav -r48000 -I \ 
> track-1.wav track-2.wav track-3.wav track-4.wav

> If I run this command on my workstation it correctly outputs my tracks,
> one per output, as espected. Same card.
> If I run it on the small box I get :
> aplay: set_params:852: Access type not available

What card does the small system have? If it has only stereo output then
this message would be expected (you are trying to play four channels on
a stereo card). 

> If I run 
> aplay -fS16_LE -twav -r48000 track-1.wav
> or simply
> aplay track-1.wav
> I get 
> aplay: set_params:857: Sample format non available

And this is on which card?

> Same results with other rates than 48000.
> I can play my tracks as espected using ardour/Jack.
> Please, could you guess why this happens ?

Those errors signal a mismatch between what the card can do and what you
are trying to play (ie: too many channels or too few, wrong sampling
rate and so on and so forth). 

-- Fernando