[PlanetCCRMA] serial midi access solved, but using port leads to deadlock?

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Fri Mar 11 09:21:02 2005

On Fri, 2005-03-11 at 06:28, Crispin wrote:
> Hello
> A while back I had some problems with the serial midi module; I could not
> use the port as a normal user, the following happened:
> > [crispin@renato crispin]$ ls -l /dev/midi01
> > crwx------    1 crispin  root      14,  18 Feb  5 14:16 /dev/midi01
> > [crispin@renato crispin]$ cat >/dev/midi01
> > bash: /dev/midi01: Permission denied
> http://ccrma-mail.stanford.edu/pipermail/planetccrma/2005-February/008008.ht
> ml
> This can be solved with two things done as root, before the "modprobe
> snd-serialmidi":
> setserial /dev/ttyS0 uart none
> chmod a+rw /dev/ttyS0
> (or something more sensible with the uucp group).
> However, when I now run a program which sends data to midi01 (i.e. seq24 or
> cat), the program hangs as soon as it tries to send data.  I can't even
> "kill 9" it as root.
> Can anyone help with this please?!

I don't have any experience with midi over a serial port... Do you see
anything in the system logs? (see /var/log/messages and the output of
the dmesg command). 

-- Fernando