[PlanetCCRMA] SuperCollider3 on FC4

Russell Johnston russell@sharpfour.net
Thu Jul 14 18:55:02 2005

>>I also tried building on Fedora Core 4 under the qemu emulator (I haven't 
>>upgraded my real machine to FC4 yet); the compile is fine there too, and 
>>sclang works.  I segfault on booting a server, but I suspect this is because 
>>I don't have the soundcard emulation working.  Can someone with a real FC4 
> I just built current CVS and it is failing to boot for me on a true fc4
> system. See below for a copy of what I get...

Oh rats, so it's not an emulation problem.  I get the same result as you
if I boot the local server, and I get "SCLang segmentation fault" if I
boot the internal server.  I'll try a debug build, and I will let you
(and I guess sc-dev) know if I can figure out what's going wrong.


> booting 57110
> a Server
> Using Altivec: no
> *** ERROR: dlopen '/usr/lib/SuperCollider/plugins/BinaryOpUGens.so' err
> 'invalid mode parameter'
> RESULT = 11
> server failed to start