[PlanetCCRMA] /proc/bus/usb and hotplug with FC2 ccrma kernels, source for FC2 ccrma kernels

Lance Blisters geoff@ngwee.ugcs.caltech.edu
Sat Jan 1 16:46:01 2005

I have fedora core 2, ccrma core and core-edge, hotplug, 
midisportfirmware-0.5, using yum

Booting 2.6.9-1.6_FC2 /proc/bus/usb is populated, 
and hotplugging works.

Booting 2.6.9-2.2.rdt.rhfc2.ccrma or 2.6.10-2.1.ll.rhfc2.ccrma 
kernel, /proc/bus/usb stays empty and hotplugging does not work.
After plugging in oxygen8, dmesg shows only:
usb 4-1: new full speed USB device using uhci_hcd and address 2

diff  /boot/config-2.6.9-2.2.rdt.rhfc2.ccrma /boot/config-2.6.9-1.6_FC2 
doesn't show any obvious problems

1. Does anyone know how to get /proc/bus/usb/ working?  Or is the root
of my problem hotplugging under ccrma kernels elsewhere?

2. I can't find the kernel source for ccrma kernels.  Am I missing 
something obvious?  I tried using yum search, only the fc2 kernels
had source packages.  Tried using apt-get source on a kernel-package,
couldn't find matching source package.  Even though I couldn't 
identify a kernel config option which was obviously responsible for 
my hotplug problems, I'd like to have the option of rebuilding the 
ccrma kernels to my liking.

[root]~# yum search kernel | grep source | grep -v alsa
Available package: kernel-source.i386 0:2.6.5-1.358 from base matches with
Installed package: kernel-sourcecode.noarch 0:2.6.9-1.6_FC2 matches with

I did find http://ccrma.stanford.edu/planetccrma/mirror/all/linux/SRPMS/kernel-2.6.9-2.2.rdt.src.rpm 
but it is not clear if/how this differs from the rdt.rhfc2 kernel.  
Could not find anything for 2.6.10-2.1.ll.rhfc2.ccrma

Please CC me on reply, I am not subscribed.