[PlanetCCRMA] Failure starting ALSA with an MAudio Delta 66

Anand Kameswaran akameswaran@yahoo.com
Fri Feb 11 18:15:02 2005

I have the same symptoms with my Delta 66.  I have two
cards, an onboard intel and the delta.  I tried
alsactrl store, I still get the complaint.  Anybody
else have ideas?  I have tried with both cards loaded,
I have tried using the intel as primary and the delta
as primary.  In the end the results are allways the
same.  Intel works, delta does not.  Mixer settings
are never saved for the delta, but the intel is fine. 
I would post my modprobe.conf except that it's almost
identical to grandparent post.  I don't really
understand the entire signal flow here, but one thing
I discovered is my Delta will play out through
/dev/dsp  and it will work when I use the OSS bridge,
just not in straight ALSA mode.  Correct me if I'm
wrong, but when using OSS and ALSA, ALSA is the driver
and it hands off to an oss compatability layer right? 
So how can the Delta work through OSS but not ALSA? 
I'm very confused.