[PlanetCCRMA] Rosegarden 0.9.91 hangs

Fernando Lopez-Lezcano nando@ccrma.Stanford.EDU
Tue Feb 1 08:17:01 2005

On Tue, 2005-02-01 at 06:05, Frode Petersen wrote:
>  > I managed to repeat the problem, apparently Rosegarden is not happy at
>  > all when started without the alsa sequencer loaded.
> I think this is the problem. There is no /dev/snd/seq (I suspect that to 
> be the correct device name for the sequencer). I suppose some module 
> isn't loaded for some reason, but how do I go about finding out why? 
> Maybe I could load the module manually to see whether there is a 
> problem; I would need to know the name of that module though.
>  >> Actually, I don't think this is Rosegarden's fault, but I just don't
>  >> know where to start looking for a solution. I can start JACK with
>  >> Qjackctl, though that program complains that it can't open ALSA
>  >> sequencer as a client, so the midi patchbay won't be available.
>  >> Then, as I start JACK through Qjackctl, the message window reports 
> what's at the end of this message.
>  >
>  >
>  > You can enable the alsasound startup script so that it loads the
>  > sequencer kernel module at startup:
>  > (as root)
>  >   /sbin/chkconfig alsasound on
>  > And you can start it manually:
>  >   /etc/rc.d/init.d/alsasound start
>  > (or reboot)
>  >
>  > Rosegarden should start fine once snd-seq is loaded (at least it did
>  > here).
> I tried that, but the result is the same. I tried to start jack and 
> rosegarden as root, just to see if it is a privilige problem, but no 
> difference. I've included this new output at the end.

See if the snd-seq kernel module is loaded (as root):
  /sbin/lsmod | grep ^snd-seq
If it is not there, load it explicitly:
  /sbin/modprobe snd-seq
Try starting rosegarden...

If you have activated the alsasound script as outlined above snd-seq
should be automatically loaded on the next reboot. 

-- Fernando