[PlanetCCRMA] Rosegarden 0.9.91 hangs

Frode Petersen fropeter@online.no
Tue Feb 1 06:07:03 2005

Thanks for the answer!

I've been poking around a bit, but my problem is that this area is 
mostly unknown to me. Do you know some site that might have an overview 
of how the different parts tie together? I'm thinking of things that I 
can look for in the filesystem or in configuration files and so on.

Fernando Lopez-Lezcano wrote:

 > On Sun, 2005-01-30 at 18:07, Frode Petersen wrote:
 >> Do any of you get Rosegarden 4 0.9.91 running? I get the splash, there
 >> are processes running according to the process list, and I have to
 >> manually kill the program.
 > I managed to repeat the problem, apparently Rosegarden is not happy at
 > all when started without the alsa sequencer loaded.

I think this is the problem. There is no /dev/snd/seq (I suspect that to 
be the correct device name for the sequencer). I suppose some module 
isn't loaded for some reason, but how do I go about finding out why? 
Maybe I could load the module manually to see whether there is a 
problem; I would need to know the name of that module though.

 >> Actually, I don't think this is Rosegarden's fault, but I just don't
 >> know where to start looking for a solution. I can start JACK with
 >> Qjackctl, though that program complains that it can't open ALSA
 >> sequencer as a client, so the midi patchbay won't be available.
 >> Then, as I start JACK through Qjackctl, the message window reports 
what's at the end of this message.
 > You can enable the alsasound startup script so that it loads the
 > sequencer kernel module at startup:
 > (as root)
 >   /sbin/chkconfig alsasound on
 > And you can start it manually:
 >   /etc/rc.d/init.d/alsasound start
 > (or reboot)
 > Rosegarden should start fine once snd-seq is loaded (at least it did
 > here).
 > -- Fernando

I tried that, but the result is the same. I tried to start jack and 
rosegarden as root, just to see if it is a privilige problem, but no 
difference. I've included this new output at the end.

 >> Of the programs I've tried, only Hydrogen works, but drums only 
doesn't make my dream soundscape...
 >> Machine and software:
 >> Thinkpad R40 w/built-in sound (snd-intel8x0 driver)
 >> FC3 kept up-to-date with synaptic
 >> PlanetCCRMA installed on top of this
 >> kernels: 2.6.10-2.1.ii.rhfc3.ccrma
 >>          2.6.10-0.2.rdt.rhfc3.ccrma
 >>          2.6.10-1.741_FC3 (installed before planetCCRMA)

I read in a post somwhere that there are (were) some problems with alsa, 
kernel 2.6.10 and udev. Could this be the reason to these problems? I do 
not know what the problems were.

Frode Petersen

This output is as user root (not how I normally start these programs)

Output from terminal:

[root@localhost ~]# qjackctl
Warning: no locale found: /usr/share/locale/qjackctl_nb_NO.UTF-8.qm

[1]+  Stopped                 qjackctl
[root@localhost ~]# bg
[1]+ qjackctl &
[root@localhost ~]# rosegarden
kbuildsycoca running...
[root@localhost ~]# Rosegarden 4-0.9.91 - AlsaDriver - alsa-lib version 

JackDriver::initialiseAudio - JACK sample rate = 48000Hz, buffer size = 1024
JackDriver::initialiseAudio - creating disk thread
JackDriver::initialiseAudio - found 2 JACK physical outputs
JackDriver::initialiseAudio - connecting from "rosegarden:master out L" 
to "alsa_pcm:playback_1"
JackDriver::initialiseAudio - connecting from "rosegarden:master out R" 
to "alsa_pcm:playback_2"
JackDriver::initialiseAudio - found 2 JACK physical inputs
JackDriver::initialiseAudio - connecting from "alsa_pcm:capture_1" to 
"rosegarden:record in 1 L"
JackDriver::initialiseAudio - connecting from "alsa_pcm:capture_2" to 
"rosegarden:record in 1 R"
JackDriver::initialiseAudio - initialised JACK audio subsystem
ALSA lib seq_hw.c:446:(snd_seq_hw_open) open /dev/snd/seq failed: Ingen 
slik fil eller filkatalog
*** glibc detected *** double free or corruption (!prev): 0x080ccc70 ***

<Here Rosegarden hangs showing the splashimage; it's status message 
indicates that it it is starting the sequencer>

Output from qjackctl message window:

11:11:20.718 Patchbay deactivated.
11:11:20.728 Statistics reset.
11:11:20.884 Could not open ALSA sequencer as a client. MIDI patchbay 
will be not available.
ALSA lib seq_hw.c:446:(snd_seq_hw_open) open /dev/snd/seq failed: Ingen 
slik fil eller filkatalog
11:11:29.591 Startup script...
11:11:29.591 artsshell -q terminate
11:11:31.026 Startup script terminated with exit status=256.
11:11:31.031 JACK is starting...
11:11:31.034 /usr/bin/jackstart -R -dalsa -dhw:0 -r48000 -p1024 -n2
11:11:31.058 JACK was started with PID=12004 (0x2ee4).
jackstart: cannot get realtime capabilities, current capabilities are:
            =ep cap_setpcap-ep
     probably running under a kernel with capabilities disabled,
     a suitable kernel would have printed something like "=eip"
back from read, ret = 1 errno == Success
jackstart: could not give capabilities: Operation not permitted
jackd 0.99.36
Copyright 2001-2003 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 48000
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 48000Hz, period = 1024 frames, buffer = 2 periods
Couldn't open hw:0 for 32bit samples trying 24bit instead
Couldn't open hw:0 for 24bit samples trying 16bit instead
nperiods = 2 for capture
nperiods = 2 for playback
11:11:33.081 Server configuration saved to "/root/.jackdrc".
11:11:33.083 Statistics reset.
11:11:33.109 Client activated.
11:11:33.112 Audio connection change.
11:11:33.138 Audio connection graph change.
subgraph starting at qjackctl-12002 timed out (subgraph_wait_fd=13, 
status = 0, state = Triggered)
**** alsa_pcm: xrun of at least 1.187 msecs
11:11:49.351 XRUN callback (1).
**** alsa_pcm: xrun of at least 3392.817 msecs
11:11:50.556 XRUN callback (1 skipped).
11:11:57.100 Audio connection graph change.
11:11:57.706 Audio connection graph change.
11:11:57.795 Audio connection change.
11:11:57.899 Audio connection graph change.
11:12:01.027 Audio connection graph change.
11:12:01.043 Audio connection graph change.