[PlanetCCRMA] Re: HDSP9652 muted on system start

Mark Knecht markknecht@gmail.com
Sun Aug 28 07:48:01 2005

On 8/28/05, Michele Spinolo <michele.spinolo@tin.it> wrote:
> Hi Dave, 
> I tried the trick you posted, but I am noticing some problems, probably due
> to some errors I am going in. 
> I added 
> hdspmixer >out 2>&1 /dev/null &
> to my rc.local file, and I can get sound out without opening hdspmixer. 
> I am used to test my setup looping RME ADI-8 Pro input and output with
> Edward Wildgooses rec_imp tool
> (http://www.duffroomcorrection.com/wiki/Simple_Automated_IR_Measuring_Tool)
> which basicly plays and records a logaritmic sine sweep and extract the
> impulse response. 
> The problem raise when I use it just starting the system: I have clips on
> recorded impulse response (ADI-8 Pro inputs clips in analog domain), while
> it doesn't happen if I open hdspmixer. 
> I suppose the line 
> hdspmixer >out 2>&1 /dev/null & 
> set recording levels at a different value of -6.0dB which should be the
> default for RME HDSP9652. 
> Can anyone provide some hint? 
> Kind regards, 
> Michele Spinolo 

Hi Michele,
   It may be because reading technical documents and looking at graphs
is always a bit difficult at 7AM on a Sunday morning, or simply that
I'm too dense to understand what the data is telling me, but so far
I'm not understanding the exact problem. Maybe you can clarify that a
bit more for me?

   I am interested as I have an HDSP 9652 also and I've had a problem
with it for over 3 years that the developers have never solved. I'm
wondering if my problem and what you are seeing have anything to do
with each other.

   If I understand what you are doing then you have Edward's program
generating a sine sweep, going to the HDSP 9652 which is attached to
the ADI-8 Pro and is converted to analog. That analog input is looped
back into the ADI-8 Pro, sent back to the HDSP 9652 and then to
Edward's program again. Is this the setup?

   Where is the clock master in this setup? Is it the HDSP 9652? Is it
the ADI-8? Is it something else? (You had a Zsys, correct?)

   The problem is that with hdspmixer closed you get some clipping,
but the clipping only happens when you start the program and then goes
away, while with hdspmixer open you do not see the clipping. Is this
the case?

   If I'm understanding both the setup and the problem correctly, then
please do some simple experiments with hdspconf. You may actually be
seeing a version of the problem I've had for years. With hdspmixer not
running open hdspconf and cjeck the frequency that the HDSP 9652 is
running at. Now run Edward's program. (You may need to run it a few
times.) Do you see the frequency of the HDSP 9652 changing? Do you see
the clock source of the HDSP 9652 changing? Note that you may need to
run the test a few times to see the frequency change in hdspconf. It
happens quickly. The indicator in hdspconf will move and then move
back and it's not always easy to see.

   I do see these change, and I See them change at strange times. I've
found that things are much better when running Jack since Jack locks
the device down to a specific frequency and Jack apps cannot change
it. However, with OSS and Alsa apps I see the freqency change at odd
times. It is worse with OSS emulation. These frequency changes are not
well managed, either in Alsa or OSS, and the driver does not ensure
that ''zero' volume data is going out the port when it changes
frequency, so when it happens I get horrible popping/scratching sounds
that will sometimes make me think my speakers have blown up.

   My setup here is similar to yours, assuming that I've described it
correctly above. If you see the same frequency changes then maybe we
can get some attention from the developers on this issue. I've found
it's worse using external clocks where the HDSP is being asked to sync
a better clock.