[PlanetCCRMA] Tascam 428 startup and inputs 3 and 4

Eric Princen eprincen@boatertalk.com
Mon Aug 22 10:59:00 2005

when I made a fresh CCRMA+FC3 install some time ago, hotplug 
worked out of the box. 
My (propably self modified) modproble.conf currently has this
relevant entries:
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
install snd-usb-usx2y modprobe snd-seq; modprobe --ignore-install
snd-usb-usx2y nrpacks=1 index=1
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx
&& /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1
|| : ; }; /sbin/modprobe -r --ignore-remove snd-via82xx

I'll try to weak mine a bit and see what happens. With mine currently,
when I hotplug I get these messages in /var/log/messages:

Aug 22 11:44:38 studio kernel: usb 9-1: USB disconnect, address 2
Aug 22 11:44:40 studio kernel: usb 9-1: new full speed USB device using
uhci_hcd and address 3
Aug 22 11:44:41 studio /etc/hotplug/usb/tascam_fpga:
calling /usr/bin/usx2yloader for /proc/bus/usb/009/003
Aug 22 11:44:41 studio /etc/hotplug/usb/tascam_fpga:
starting /usr/bin/us428control for /proc/bus/usb/009/003
Aug 22 11:44:41 studio /etc/hotplug/usb/tascam_fpga: leaving

Which looks good, but if I've cycled the power on the 428, the USB LED
on the unit does not light. us428control does not actually run either:

[root@studio mysql]# us428control
mmap failed:: Device or resource busy
us428control: cannot open hwdep hw:1
us428control: cannot open hwdep hw:2
us428control: cannot open hwdep hw:3
us428control: cannot open hwdep hw:4
us428control: cannot open hwdep hw:5
us428control: cannot open hwdep hw:6
us428control: cannot open hwdep hw:7
us428control: no US-X2Y-compatible cards found

If I manually run usx2yloader, everything is fine. I'm not sure
why /var/log/messages looks like it is running usx2yloader, but it
evidently isn't.

I'll fool around and see what I can find.

Yes, see above. Its the "nrpacks=1". Also you need a modified jack.
Well its only jack's alsa-usx2y driver that needs tweaking.
Attached is the patch, which I've also sent to the jack-guys.
If you have that modified jack installed,
make sure you specify the alsa-pcm device like this:
        $ jackd -dalsa -dhw0,2
the important part is the ",2".
qjackctl has a convenient dropdown menu to choose "the right thing".

Thank you. I'll try that.

> BTW, Ardour is pretty sweet. Is there any documentation on 
> us428control?

Doc is currently "read the source" only.

OK. If I have a chance do to some docs, would you like them? Perhaps I
can add some value? I'm tight on time, but isn't everyone? :-)

Last time i checked the STOP/PLAY Buttons worked.
Not sure about the rest.

OK. I'll see what I can find.

Have fun,

I will. Thank you for your help.

-Eric ;-)