[PlanetCCRMA] VirMidi Module Problem

John Pritchett John Pritchett <johnadon@gmail.com>
Thu Apr 14 17:02:02 2005

Apologies for the following which is really terribly insignificant in
the grand scheme of things - but I've become completely obsessed with
it. :) For some reason I'm having various problems loading the virmidi
module since I started using the Planet CCRMA distribution. I've been
able to solved all of them fairly easily up to the present problem.
Currently with newer kernels I've installed from ccrma, whenever I try
to modprobe -a snd-virmidi, I get an "Error inserting snd_virmidi. No
such device." I used to be able to overcome this problem by running
the snddevices script manually in the alsa driver source (before I
discovered that you could 'chkconfig alsasound on' to get everything
to run by itself at boot time. :)  I get the same error message when
the modules tries to load whenever I run the alsasound script

The virmidi module still finds the appropriate devices when I boot my
2.6.11-0.3.rdt.rhfc3.ccrma kernel, but not with any other kernels. I
double checked the /dev/snd devices for the appropriate midi devices
for Virmidi and they are present in that directory. I also have
checked (many times) my modprobe.conf to ensure that it hasn't changed
anything behind my back, but it still lists for my virmidi setup

alias snd-slot-1 snd-card-1
alias snd-card-1 snd-virmidi

just as it always has. I've also compiled and installed alsa-drivers,
used a hammer on the cpu, etc.

I've also noticed booting into the kernels that 'don't work' (they
actually work exceedingly well otherwise) there is a listing for a
Midi Through device when I peek into qjackctrl's Connections window...
Does this relate to my problem? What exactly IS the Midi Through I see

All this just to be able to send sysex from JSynthlib to Hexter DSSI
DX7 softsynth. :) Also, if anyone could tell me why I've become
obsessed with making this work with the other kernels, I'd appreciate
it.  Thanks so much for any help and apologies if I should have
pointed this question elsewhere!!

John Pritchett