[PlanetCCRMA] FC2.1vP9 - jackstart just quits...

Mark Knecht Mark Knecht <markknecht@gmail.com>
Wed Sep 29 19:48:01 2004

On Wed, 29 Sep 2004 22:14:29 -0400, Steve Blackwell <zephod@cfl.rr.com> wrote:
> On 29/09/04 21:33:41, Mark Knecht wrote:
> <SNIP>
> >
> >    Still looking. I'm going to try the original Fedora kernel later
> > this evening, and also try with realtime-lsm loaded and not loaded,
> > as
> > root and not root, etc.
> >
> Mark,
> I am running an almost stock FC2 kernel (recompiled to make the
> SECURITY_CAPABILITIES a module instead of compiled in) and I made the
> realtime_lsm module.
> As root I run:
> # modprobe realtime allcaps=1 any=1
> and then as a normal user I run
> $ jackstart -v -R -d alsa
> I get almost the same output as yours except for some lines about being
> unable to open hw:0 for 32bit or 24bit samples which is probably due to
> my old Live soundcard. The only other difference I see is that I have
> jack 0.98 whereas you have 0.99.
> Don't know if this helps but it may be a reference point for you.
> I'm just trying to get my head around this Linux sound/ALSA/JACK/low
> latency/preemption/IRQ/etc/etc/etc thing. Jeez!
> Steve.

   Hi. By "I get almost the same output as yours except..." do you
mean that you do not see any verbose messages from Jack when you are
running? (from the '-v' option)

   I've tried this under a number of kernels. I cannot run the
standard Fedora kernel as the Alsa included is too old to support this
sound chip. (It's there but it doesn't configure correctly and unloads
Alsa. I see this under Gentoo for the same revision of Alsa)

   Here's an interesting test. With Fernando's more recent PlanetEdge
kernel, with is based and called .1vR9 I still do not receive
interrupts from my sound card but Jack does not time out and die. It
just sits there. So for fun I start up alsaplayer -o jack and to my
surprise (sort of) alsaplayer starts and doesn't die. I insert Nora
Jones and start alsaplayer playing the CD. Nothing happens. Then I
start wiggling my mouse and Nora Jones starts playing perfectly. When
I stop wiggling my mouse alsaplayer just keeps looping on a single
frame, or group of frames. When I start wiggling the mouse again
alsaplayer starts playing the CD again.

   So, obviously, I just need to wiggle my mouse all night and I'm
fine, right?!? ;-)

   It looks pretty clear that the system is not seeing interrupts from
my sound card. I do a cat /proc/interrupts and with the mouse still
the interrupt count doesn't increment.

   I wonder how I go about working this out? Is it through Fernando?
Some other path? this sort of thing, and how to communicate it to
kernel developers, would be very far beyond my meager capabilities.

   I've also been looking at scanpci and pcitweak to see if I can find
problems in the PCI config space but that's very slow going...

   Thanks for chiming in. Maybe we can figure out whether this is a
problem specific to my hardware or something more people are going to
have in common. What sort of hardware are you using?