[PlanetCCRMA] Re: evolution mk-249c USB MIDI controller help

Paul Coccoli Paul Coccoli <pcoccoli@gmail.com>
Wed Sep 22 19:36:02 2004

Problem solved.  I had some mistakes in my modules.conf, and I need to
add the OSS "audio" and "usb-midi" modules to /etc/hotplug/blacklist.

FYI, the guide linked in my previous message seems to be out of date. 
Instead of snd-usb-midi (which doesn't exist on my box), I had to use
snd-usb-audio.  Otherwise, the sample modules.conf they give is a good

How the hell is anybody supposed to figure this stuff out?  I've been
running Red Hat since 1997 and it took me months.  I plan a more
thorough write-up, but it's late...

Oh, and the problem was hard to debug due to a bad USB cable.  With a
good cable, I at least got some error messages I could work with.

On Thu, 19 Aug 2004 22:04:03 -0400, Paul Coccoli <pcoccoli@gmail.com> wrote:
> I'm stumped.  I'll admit it.  I don't know what all those ALSA snd-seq
> modules do.  I don't know if I need to add snd-usb-audio to my
> /etc/modules.conf.  Here's what I do know: USB is working on my box
> (Red Hat 9 + planet), because I can plug in my USB qwerty keyboard and
> I see activity in /var/log/messages (and I'm typing this message using
> it).  When I plug in the mk-249c, nothing shows up in
> /var/log/messages (or qsynth).
> This page was no help:
> http://www.djcj.org/LAU/guide/evolution-usb-midi.php, despite a
> promising title.
> My box is a Shuttle XPC, model number sk41g.  I have a M-audio Delta
> 66 set up and working fine (thanks to Planet CCRMA).  There's built-in
> sound too, but I don't use it (disabled in BIOS).
> [paul@localhost paul]$ cat /proc/asound/cards
> 0 [M66            ]: ICE1712 - M Audio Delta 66
>                      M Audio Delta 66 at 0xc000, irq 17
> What should modules.conf look like?  Do I need to have an asoundrc file?
> [paul@localhost paul]$ uname -a
> Linux localhost.localdomain 2.4.26-1.ll.rh90.ccrma #1 Fri Apr 16
> 21:56:56 PDT 2004 i686 athlon i386 GNU/Linux
> Would anything else be helpful?  Has anyone gotten this keyboard
> working with USB?  It worked on another machine using the game port on
> an SBLive!.
> Any help would be appreciated,
> paul