[PlanetCCRMA] Planetedge Q3

Matt Barber brbrofsvl@aol.com
Wed Sep 22 17:25:01 2004

->Just today I managed to get a kernel with voluntary S3 (on top of
2.6.9-rc2-mm1) compiled, but my first try at booting it on an athlon64
machine was unsuccessful, something to do with usb devfs which left me
with no keyboard or mouse... I have not tried a cold boot yet.<-

I had a similar problem with mouse/keyboard in the Q3 kernel when I was
building - there were some things that seemed totally unrelated when I
was trying to configure the kernel (all I was playing with was the sata
support) - in most cases I couldn't boot at all, but in other cases
where I did manage to boot, the keyboard and mouse wouldn't work.  I
think one such configuration was when I tried compiling sata support for
all of the controllers into the kernel, and then making another initrd
that had the sata_sil module in it - it would boot but then it seemed
like the kernel was confused how to handle the support for the other
controllers.  I should have taken better notes, but I'm certain that in
my case it was a problem with the initrd (as I couldn't get any to even
get through a boot unless I made the initrd myself, which is of course a
problem if you want to put together an rpm - in my case the only way the
kernel works is if the sata driver is in the kernel and an initrd
module... kinda weird).