[PlanetCCRMA] apt-get install planetccrma-audioapps - dependency errors on FC1 (solved)

Jonathan Marsden jonathan@grcomputing.net
Tue Oct 26 20:55:03 2004

Dependencies are not fun.

On Tue, 2004-10-26 at 20:19, Jonathan Marsden wrote:

> Then I tried
>   apt-get update && apt-get install planetccrma-audioapps
> and it fails with errors about several packages having dependency
> problems! ...

It turns out that I had apparently done an apt-get update before
replacing the default sources.list file with the CCRMA one.  As a
result, apt knew about other sources and used them... removing apt,
apt-devel and synaptic, rm -rf /etc/apt /var/cache/apt and then
reinstalling apt and apt-devel and moving the CCRMA apt.conf and
sources.list into place *before* doing an apt-get update ... half

This time, several audio apps would not be installed because of the
apparent lack of libmad.  After a little more Googling, I tried

  apt-get install libmad

which insisted on removing a couple of existing RPMs (!), but otherwise
worked.  Then (at last!) 

  apt-get install planetccrma-audioapps

did its thing as expected.

I suspect that the Planet CCRMA at Home instructions work if (a)
followed EXACTLY and (b) used on a machine that has had nothing but
Fedora Core RPMs added to it.  Otherwise... life may get interesting.

Anyway, the audio apps are downloading now :-)  Apologies for asking the
list and then solving my own problem!

Jonathan Marsden <jonathan@grcomputing.net>
Making electronic communications reliable for Christian missions worldwide