[PlanetCCRMA] apt-get install planetccrma-audioapps - dependency errors on FC1

Jonathan Marsden jonathan@grcomputing.net
Tue Oct 26 20:20:02 2004

I'm a pretty old hand with Linux (used since 1992), but new to using it
for audio.

I run FC1 on a 2.66GHz P4 with 512MB RAM/40GB HD, and just the built in
motherboard sound capability (intel i810).  I decided to try to get
Planet CCRMA @ Home running on this machine as a first step (a real
sound card will probably follow once I can demonstrate the basic idea!).

Installing apt went fine, as did installing the new kernel, and alsaconf
found the "sound card", a reboot shows the new ALSA modules loaded,
hdparm tweaks fine... all the "hard part" was easy :-)

Then I tried

  apt-get update && apt-get install planetccrma-audioapps

and it fails with errors about several packages having dependency

OK, I tried an apt-get upgrade and that installed 25 RPMs (odd, because
I use a yum repository to auto-update against every day, but anyway, it
worked).  However, I still get:

> The following packages have unmet dependencies:
>   planetccrma-audioapps: Depends: brutefir but it is not going to be installed
>                          Depends: freqtweak but it is not going to be installed
>                          Depends: gem but it is not going to be installed
>                          Depends: jaaa but it is not going to be installed
>                          Depends: jamin but it is not going to be installed
>                          Depends: pvoc but it is not going to be installed
> E: Broken packages

from the apt-get install planetccrma-audioapps command.

If I try adding these app names to the command, to see what the issues really are, I get:

> 19:44:17 root@jm:/etc/apt# apt-get install planetccrma-audioapps  brutefir freqtweak gem jaaa jamin pvoc
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
>   brutefir: Depends: libfftw3f.so.3
>   freqtweak: Depends: libfftw3f.so.3
>   gem: Depends: libfreeglut-1.3.so.0
>   jaaa: Depends: libfftw3f.so.3
>   jamin: Depends: libfftw3f.so.3
>   pvoc: Depends: libfftw3f.so.3
> E: Broken packages
> 19:45:22 root@jm:/etc/apt# 

So, I grabbed the list archives and have grepped them for relevant
messages, and not found anything clearly related to this issue.

I'm now off to track down these missing libraries via Google and
freshrpms, but I probably "shouldn't" have to do that... so what did I
do wrong?

Thanks in advance,

Jonathan Marsden <jonathan@grcomputing.net>
Making electronic communications reliable for Christian missions worldwide