[PlanetCCRMA] difficulty installing ccrma kernel

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Tue Oct 26 11:06:01 2004

On Tue, 2004-10-26 at 00:31, Joakim Verona wrote:
> Ive been using ccrma and apt-get for some time now withouth problems.
> Encouraged by this I recently tried doing apt-get dist-upgrade.
> Ever since nothing works very well.

Hmmm, could you be more specific? This does not tell me anything...

> Here is my attempt at upgrading the kernel now:
> [root@naru apt]# apt-get -o RPM::Install-Options::=--oldpackage
> install planetccrma-core-smp
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> Since you only requested a single operation it is extremely likely
> that
> the package is simply not installable and a bug report against
> that package should be filed.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
>   planetccrma-core-smp: Depends: kernel-version-smp-athlon (=
>   2.4.26-1.ll.rh90.ccrma)
>                         Depends:
>   alsa-kernel-smp-2.4.26-1.ll.rh90.ccrma-athlon (=
>   1.0.4-1.cvs.rh90.ccrma)
>                         Depends:
>   midishare-kernel-smp-2.4.26-1.ll.rh90.ccrma-athlon (=
>   1.86-4.rh90.ccrma)
>                         Depends: alsa-driver (=
>   1.0.4-1.cvs.rh90.ccrma) but 1.0.6a-31.rh9.at is to be installed
>                         Depends: alsa-lib (= 1.0.4-1.cvs.rh90.ccrma)
>   but 1.0.6-16.rh9.at is to be installed
>                         Depends: alsa-lib-devel (=
>   1.0.4-1.cvs.rh90.ccrma) but 1.0.6-16.rh9.at is to be installed
>                         Depends: alsa-utils (= 1.0.4-1.cvs.rh90.ccrma)
>   but 1.0.6-10.rh9.at is to be installed

You have two options. Either disable atrpms or install the kernel
manually. The "planetccrma-core-*" has very specific requirements and
those match specific versions of alsa. At this point in time atrpms has
newer versions than the ones available at Planet CCRMA, so those get
selected and "conflict" with the requirements of planetccrma-core-*.

So, you can disable atrpms (comment out the urls from sources.list and
do an "apt-get update") and then install the kernel "manually" by doing
  apt-get install kernel-smp
that will list all the available kernels, then select the one you want,
probably this is what you want:
  apt-get install kernel-smp#2.4.26-1.ll.rh90.ccrma

After that you should be able to do an "apt-get dist-upgrade" to update
everything. Be aware that on another thread someone has been having
problems with atrpms because of different naming scheme of some

I don't remember if the dependencies will cause the alsa-kernel package
to be pulled in, you may have to install that manually. 

> I dont know what causes this, except that ccrma and at repositories
> are somehow incompatible. How do I explain to apt-get that I prefer
> ccrma rpm:s in this case?
> I tried various things that doesnt help, like trying to disable the at
> repository in my sources.list, and so on.

Strange, that should have helped (unless you already have newer versions
of alsa-* installed that the ones available at Planet CCRMA, I guess). 

> I have other problems as well, as it seems dag and at repositories
> arent all that compatible either. Specifically the bitlbee rpm from
> the dag repository doesnt want to install with the at repository
> enabled.

In some cases the atrpms repository seems to be choosing different
naming schemes than the rest of the repositories (see the fftw* thread,
for example). While they may be more "rational" they produce conflicts,
so at this point it looks to me that trying to mix Planet CCRMA and
atrpms is not good. Most probably dag and freshrpms do not have those

> Maybe all of these problems can be resolved with some priority scheme
> that surely apt-get has, but which has eluded me so far. Any hints apreciated!

That is called "pinning" but I'm not an expert. Supposedly the atrpms
configuration has that enabled with different priorities for each
repository, maybe something has changed and broken that. 

Check what you have in /etc/apt/preferences...

-- Fernando