[PlanetCCRMA] difficulty installing ccrma kernel

Joakim Verona joakim@verona.se
Tue Oct 26 00:32:01 2004


Ive been using ccrma and apt-get for some time now withouth problems.
Encouraged by this I recently tried doing apt-get dist-upgrade.

Ever since nothing works very well.

Here is my attempt at upgrading the kernel now:

[root@naru apt]# apt-get -o RPM::Install-Options::=--oldpackage
install planetccrma-core-smp
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  planetccrma-core-smp: Depends: kernel-version-smp-athlon (=
  alsa-kernel-smp-2.4.26-1.ll.rh90.ccrma-athlon (=
  midishare-kernel-smp-2.4.26-1.ll.rh90.ccrma-athlon (=
                        Depends: alsa-driver (=
  1.0.4-1.cvs.rh90.ccrma) but 1.0.6a-31.rh9.at is to be installed
                        Depends: alsa-lib (= 1.0.4-1.cvs.rh90.ccrma)
  but 1.0.6-16.rh9.at is to be installed
                        Depends: alsa-lib-devel (=
  1.0.4-1.cvs.rh90.ccrma) but 1.0.6-16.rh9.at is to be installed
                        Depends: alsa-utils (= 1.0.4-1.cvs.rh90.ccrma)
  but 1.0.6-10.rh9.at is to be installed

I dont know what causes this, except that ccrma and at repositories
are somehow incompatible. How do I explain to apt-get that I prefer
ccrma rpm:s in this case?

I tried various things that doesnt help, like trying to disable the at
repository in my sources.list, and so on.

I have other problems as well, as it seems dag and at repositories
arent all that compatible either. Specifically the bitlbee rpm from
the dag repository doesnt want to install with the at repository

Maybe all of these problems can be resolved with some priority scheme
that surely apt-get has, but which has eluded me so far. Any hints apreciated!