[PlanetCCRMA] BasiliskII on RedHat 9 failing

Chris Miles (PlanetCCRMA) PlanetCCRMA@ir.compulink.co.uk
Fri Oct 1 17:08:02 2004


I've just had to re-install RedHat 9 after PartitionMagic 8.01 trashed
my root partition.

I decided to go with the Low Latency Planet kernel.

All has gone well until I got to the Basilisk II 86k Mac emulator.
Nothing I can find works.

I've tried the original, RedHat Planet and LL Planet kernels; all no joy.

I've tried BasiliskII 0.9 and 1.0 (different crash but neither work).

I've tried the stock nv screen driver rather than Nvidia's 6111 release
(I've a nForce2 Shuttle motherboard).

I've tried compiling with debug symbols (-g or -ggdb) but gdb does not
like the info so no decent trace :-( The problem appears after the main
thread is left and gdb does not catch the fault, so no backtrace available.

Has the team any ideas?
I get a 20 second delay while X comes up (there is probably little
interrupt activity); I can live with that.
Otherwise the sound performance is good. VMware stretches it too much,
but that's OK.