[PlanetCCRMA] Re: jack_fst - Library requirements

Mark Knecht Mark Knecht <markknecht@gmail.com>
Mon Nov 29 21:31:01 2004

On Tue, 30 Nov 2004 14:30:38 +1100, Shayne O'Connor
<forums@machinehasnoagenda.com> wrote:
> hi mark
> > I guess my input would be to start over from scratch. Erase all the
> > directories, reinstall the jack_fst and fst code, reload the Steinberg
> > files, etc.
> well, i wiped all the directories and files and started again (which was
> a good idea, because it appears i had a lot of invisble files in those
> directories, looked a bit messy) - and ... SUCCESS!!!
> > This is a tough program to install and get working. Took
> > me over a month what with these sorts of compile problems, problems
> > with different versions of Wine, and then working to get the jack_fst
> > patch.
> yes, well the first thing i did was to fire up jack and then muse, and
> then i tried running Crystal with jack_fst, it pops up for a second like
> it did for andres, and then i get the segmentation fault ...
> > [mrmachine@localhost mrmachine]$ jack_fst /home/mrmachine/linux-progz/audio/vst_plugins/Crystal.dll
> > err:dosmem:setup_dos_mem Cannot use first megabyte for DOS address space, please report
> > Please use the registry key HKEY_CURRENT_CONFIG\Software\Fonts\LogPixels
> > to set the screen resolution and remove the "Resolution" entry in the config file
> > Segmentation fault
> i'm using wine 20040914 on fedora core 2 - should i downgrade to 20040505, or use that jfst.c patch for the 20041019 version of wine and recompile jack_fst?

Use the jfst.c patch. It's easier to add than recompiling wine. that
said the patch should work with either version. If you have added that
patch and still get the segfault then try downgrading Wine I suppose.

> after installing the appropriate version of wine (which one are you currently using - still the 20040505?), i'll probly wipe fst and jack_fst again, start from scratch just to make sure.

I use 20041019.

> thanx for taking the time from your own troubles to help out :)

No prob. Wanna know what I'm up against? I uninstalled GigaStudio and
now Win ME won't even boot. What a joke that OS is. It's tough to have
no options...

- Mark