[PlanetCCRMA] alsa kernel modules: invalid module format

Samuel Sieb samuel@sieb.net
Sat Nov 6 19:32:02 2004

Fernando Pablo Lopez-Lezcano wrote:
> On Sat, 2004-11-06 at 14:46, Samuel Sieb wrote:
>>I installed FC2 on a computer, then upgraded to Planet CCRMA, but I 
>>can't get the sound to work now.  It's a Pentium 133.  I get a stream of 
>>the following messages when I try to load a sound module:
>>WARNING: Error inserting snd_sb16_dsp 
>>Invalid module format
>>One line for every module in the dependency list.  It originally 
>>installed the i686 version of 
>>but I've changed it to the i586 version and it still does exactly the 
>>same thing.  The kernel is 2.6.7-1.437.1.ll.rhfc2.ccrma.  It would be 
>>really nice to get it working again, since this is my jukebox...
> If you replaced by hand the i686 kernel with the i586, did you also
> replace the kenrel-module-alsa with the one that matches the
> architecture (ie: i586)? Both must have the same architecture. 
> -- Fernando
It was the i686 *alsa* package that I replaced with the i586. But I just 
reinstalled the i586 version of the kernel just to make sure and the 
depmod at the end of the install spit out lots of these messages:
needs unknown symbol get_user_size
needs unknown symbol put_user_size

And I still get the same error when trying to load them.