[PlanetCCRMA] First impressions (and a couple of minor issues)

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Sat May 15 19:29:01 2004

> I've just installed Fedora Core 1 and Planet CCRMA on my new laptop and 
> I'd just like to say how impressed I am with the way everything has just 
> worked with hardly any fiddling.  Last time I was doing a lot of linux 
> audio stuff I seemed to spend half my time trying to configure stuff so 
> it really makes a huge difference. 

It depends on when it was you last tried, things have changed for the
better consirably in the past, let's say, two years. 

> So, a big thank you to everyone involved for making it all so easy.

Thanks, and glad it is working for you...

> There's just a couple of things that don't seem to be working quite 
> right.  When I try to run muse it says
> [nev@sherka nev]$ muse
> no locale <muse_en_GB.UTF-8>/</usr/share/muse/locale>
> open projectfile: No such file or directory
> JACK: sample rate changed: 44100
> NO Config File </home/nev/.MusE>
> cannot open rtc clock /dev/rtc: Permission denied
> Segmentation fault

You could try changing the permissions of /dev/rtc so that the device is
world writable (as root, do: "chmod +w /dev/rtc"). Plus you will
probably need to increase the timing resolution (for non-root users)
available from /dev/rtc, you can do that by saying:
  echo "1024">/proc/sys/dev/rtc/max-user-freq

_But_, I just tried this on my FC1 laptop and did not work :-( It says:

  cannot set tick on /dev/rtc: Permission denied
  precise timer not available

Starting muse with jack running avoids the problem...

> Also, the rdf data for the swh and cmt plugins doesn't seem to be there 
> as they all show up in ardour as type 'unknown'.

I discovered this by chance a couple of days ago while rebuilding for
FC2 test3 (because of the new build system I'm using). It will be fixed
in the next rebuild. 

Thanks for the feedback!
-- Fernando