[PlanetCCRMA] ALSA: Cannot restart alsa - FC1 - ICE1712

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Thu May 6 11:14:01 2004

> I am somewhat new to the list, but have been lurking for a while.  I've
> recently installed the PlanetCCRMA audio packages on FC1 and have a bit of
> problems with alsa.
> Alsaconf runs correctly, and finds my Delta 44 (ICE1712.)  It modifies my
> /etc/modules.conf with the correct settings as far as I can tell.
> The first time I did this, it worked fine.  However when I reboot, no sound.

What does the startup sequence say? Does it complain about not being
able to start alsa? Or does alsa start (apparently) fine? Once you are
up and running after the reboot, what does "cat /proc/asound/devices"

> So I try to /etc/init.d/alsasound restart.  This fails reporting _Device or
> resource busy_ for each associated module.  Of course rmmod does not work
> either, returning the same error.

rmmod of which kernel module?

Hmmm, this could also be a "kernel oops", search /var/log/messages to
see if there is one there. That would also make the modules busy and
impossible to remove. 

> I've tried ps -aux grepping for anything _sound_ related, but cannot find
> anything.  Kudzu is not running so I don't think any OSS stuff is loaded.
> Certainly nothing OSS related is showing up with a lsmod.

You could try a "fuser /dev/snd/*" to see if something shows up. 

> If I remove the Alsaconf portions of /etc/modules.conf, reboot, and re-run
> alsaconf, it will work, until I reboot the next time repeating the behaviour
> expressed above.

-- Fernando