[PlanetCCRMA] Planet CCRMA New Installation - Hang

Cliff Kotnik clkotnik@adelphia.net
Tue May 4 11:02:00 2004

I am having trouble getting planet CCMRA running on my Dell Inspiron 
7000 laptop on which I have been running Redhat 9 and Fedora Core 1.  I 
get the kernel and alsa installed.  The alsaconfig script runs okay and 
I can get the basic sound functioning.  Some of the CCRMA supplied sound 
applications work (eg. audacity).  Others (eg. noteedit) hang the 
machine.  The hang is complete to the point where alt-ctlr-bs and 
alt-ctlr-del do not break out.  I am forced to remove power and battery 
to reboot.  I have tried a number of things to try to locate and correct 
the problem without success.  I'd appreciate additional debugging 

Sound hardware is ESS Technology ES1968 Maestro 2

Here is what I have tried:

1)I started with the CCRMA CDs for FC1 and performed a complete new 
install of the OS, CCRMA low latency kernel, alsa drivers with the 
dist-upgrade, etc. per the documentation.  The alsaconf script works and 
basic sound worked.  This produced the problem described above.  I 
checked for errors in /var/log/messages, ~.xsession-errors and 
/var/log/XFree86.0.log.  In messages there were complaints from 
modprobe: "Can't locate module sound-slot-1" and 3 others about slot-1.  
I assume that  this is  something looking for a 2nd  sound card as my 
ess1968 is configured as slot-0.   There were a couple of warnings in 
the XFree log about unusable frequencies.  .xsession was clean .  The 
stderr of  one of the failing applications, noteedit, produced the error 
"_KDE_IceTransmkdir: Owner of /tmp/.ICE-unix should be set to root.

2) After various unsuccessful attempts to disable various XFree 
acceleration options on the graphics card (ATI Rage Mobility), I decided 
to try the kernel supplied on the CCRMA CDs without the low latency 
feature.  The results were the same.

3) I dropped back to Redhat 9 and repeated the installation from scratch 
using the low latency kernel.  The only significant difference was that 
I selected the KDE package set which I had skipped in 1), above.  I did 
this based on the KDE error.  Again basic sound and some applications 
work.  Others hang the machine in the same way.  I tried removing 
various hardware drivers.  I stopped PCMCIA.  I switched XFree over to 
the VESA driver from ATI.  Still the same thing and a lack of errors 
pointing me at a problem area.  If I disable the alsa drivers and 
reinstall the OSS free ones, noteedit does not hang the system.  It does 
complain about the absence of alsa.

Thanks for any suggested additional steps I can take.


Cliff Kotnik