[PlanetCCRMA] Re: Stuttering via HDSP, Cardbus, Multiface?

derek holzer derek@x-i.net
Fri Mar 26 03:30:02 2004

Hi all,

>>My machine has is 2.8 Pentium 4, plenty of horsepower, and two pcmcia 
>>slots (only one works with hdsploader for some reason).
> wait ... i can only use one cardbus slot, too ... can you check the
> irqs of your slots? (mine are 5 and 11)

There are two types of PCMCIA slots: type I and type II. My guess is 
that Type II has double bandwidth, and therfore is the only one which is 
suitable for the HDSP. I also have an HDSP, and I can confirm that only 
one slot works with it, the one which 'cat /proc/interrupts' and 'lspci 
-v' reports as a Type II, irregardless of IRQ.

I have a very unrecommended cardbus controller in my laptop [Ricoh], and 
it caused me a world of hurt getting the HDSP running. Can you tell us 
what cardbus controller you have in your laptop?

A few things that I tried in the long battle of getting my HDSP working:

1) Boot with acpi=off or pci=noacpi in your bootloader arguments. This 
got the card onto a mostly reasonable IRQ arrangement. The HDSP shares 
IRQ 9 with lots of stuff [usb, onboard soundcard, eth0, etc], but isn't 
forced to 11, where it has lower priority than all that stuff and on top 
of that is sharing with the graphics controller. Or IRQ 5, which I got 
from time to time and is totally inappropriate for audio. Come to think 
of it, if your HDSP is on IRQ 5, it might just explain your terrible 
playback and sluggish response. hmmmm........

2) Switched distros several times. I know it sounds like voodoo, but I 
really believe that something in the automagic configurations which 
Mandrake and Red Hat do made an unhealthy situation for my pcmcia 
bridge. I noticed much fewer problems running the HDSP with Debian, and 
almost none at all running Gentoo, which my laptop currently runs under. 
  With Mandrake or Red Hat, the situation was hopeless, and I exhausted 
several mailing lists with questions about how to get it right ;-)

This distro thing worked out great for me, but flies in the face of 
logic for many Linux folks, who assure me that the only real difference 
in distros is the package manager. Of course, it's the most radical 
solution, and maybe not the one for your problem. Start with your ACPI 
settings and check your IRQs and then maybe you'll see what needs to 
happen next.

Good luck,

derek holzer ::: http://www.umatic.nl
---Oblique Strategy # 55:
"Do the last thing first"