[PlanetCCRMA] Re: PlanetCCRMA digest, Vol 1 #658 - 16 msgs

Evans Winner evans_winner@mail.com
Sun Mar 21 00:55:02 2004

> From: Fernando Pablo Lopez-Lezcano <nando@ccrma.Stanford.EDU>

> Yuck, sorry about that, it works here on my two fc1 test systems. A few
> questionss. Are you completely up to date in all packages? (apt-get
> dist-ugprade). Second, does it make a difference if you do a:

Yes.  I mean, I believe so, but I'm new to apt (along with all the rest) so I could be wrong.  I was getting some error code 6 returned from rpm while trying to do some upgrades, but I think  have it figured out.  I tried removing various combinations of cmucl and cm-cmucl and clm-cmucl etc. and reinstalling them ( I don't really understand how the dependency structures with all that works yet, so I was really just fiddling around).

>   LD_ASSUME_KERNEL=2.2.5 /usr/bin/lisp

Exactly the same.  Segmentation fault.

> Third, what kernel are you running?
I am using Kernel 2.4.22-9.23rc3.11.rhfc1.ccrma.  I also tried booting into  Kernel 2.2.22-1.2115.nptl and got the same.

I found something in the archives from just a few days ago about chmoding lisp.h, but either I didn't understand it or it didn't work.

Anyway, I have no idea where I went wrong yet, but I tried using synaptic and took the downgrade option for cmucl.  My version of cmucl was 2003.12-2.rhfc1.ccrma and I downgraded to 2003.12-1.rhfc1.ccrma.  And now it looks like it works fine, though I wouldn't know how to do a serious test.  But no more seg fault.  Anyway, I'm a total newb for the whole environment.  Sorry I couldn't give more intelligent info.


Sign-up for Ads Free at Mail.com