[PlanetCCRMA] Can't start Timidity

Tony Upton celticmusicguy@hotmail.com
Wed Jun 9 03:11:02 2004

----- Original Message -----
From: "Fernando Pablo Lopez-Lezcano" <nando@ccrma.Stanford.EDU>
To: "Tony Upton" <celticmusicguy@hotmail.com>
Cc: <planetccrma@ccrma.Stanford.EDU>
Sent: Tuesday, June 08, 2004 6:48 PM
Subject: Re: [PlanetCCRMA] Can't start Timidity

> On Tue, 2004-06-08 at 15:30, Tony Upton wrote:
> > I recently found my way to Planet CCRMA, and after a lot of research
> > on the Internet and trying various things I seem to have everything
> > working beautifully...except for one thing. I can't seem to get
> > Timidity to start at all. It won't start as a normal user or as root.
> > I had thought it might be a problem with the file permissions on the
> > Timidity program itself - I had the same problem with Muse, but was
> > able to resolve it by doing an "su root" followed by a "chmod u+s" on
> > the Muse program file as suggested elsewhere on this list. I tried
> > that with Timidity and it didn't seem to work. I'm using Fedora Core 1
> > with the Planet CCRMA low latency kernel (2.4.26-1.ll.rhfc1.ccrma).
> > Any thoughts/ideas/suggestions would be appreciated.
> How does it fail? Error messages?
> Do you have the soundfont installed?
>   rpm -q -a | grep timidity
> -- Fernando

The result of "rpm -q -a | grep timidity" is "timidity++-2.11.3-8". (I
assume this is telling me the version of Timidity I have installed...I'm a
Linux newbie, so please excuse my ignorance.) Timidity seems to work fine
when I run it from a command line (which I have to admit I hadn't thought of
trying earlier) - I was able to play MIDI files and convert them to wave
files. I just can't seem to get Timidity to start from the "Sound & Video"
menu in KDE, even after using Qsynth to load a soundfont. (Qsynth doesn't
produce any errors as far as I can tell.) It looks like Timidity tries to
load for about a minute or so, then just quits trying without giving me any
error message. As long as I can run Timidity from the command line, I should
be able to do what I want to do with it.

I hope this is what you're looking for. If not, please let me know and I'll
try to dig up whatever you might need. Thanks for your help, and for all
your hard work on the Planet CCRMA package. I'm glad I found my way to it!

Tony Upton