[PlanetCCRMA] Jack wont start

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Sat Jul 17 21:13:01 2004

On Sat, 2004-07-17 at 12:57, Bryon White wrote:
> I have finished installing all the applications and wanted to run Ardour. I tried to start jack
> first by doing jackstart -R -d alsa -d hw -r 44100  command and get
> loading driver ..
> apparent rate 44100
> creating alsa driver ... hw|hw|1024|2|44100|0|0|nomon|swmeter|-|32bit
> configuring for 44100hz, period = 1024 frames, buffer = 2 periods
> couldnt open hw for 32 bit samples trying 24 bit instead
> couldnt open hw for 24 bit samples trying 16 bit instead
> Alsa: cannot set number of periods to 2 for capture
> Alsa: cannot configure capture channel

You could try with different number of periods other than the default of
2. See "man jackd" for all options. "-n 3" will set the number of
periods to 3 as in:

jackstart -R -d alsa -d hw -n 3 -r 44100

You may also need to play with the length of the period at the same time
("-p" option, default is 1024). 

Another option to test is run playback only with the -P option (just to

-- Fernando

> cannot load driver module alsa.
> I am using a KORG 1212 IO sound card that works ok with windows 98 and Sonar.
> All the installation seemed to go OK except I could  not understand alsa mixer. I tried "m" to mute
> and unmute but did not see any difference in the display. I tried qamix and it does not show
> anything in its display. I tried opening different XML files and could not get any presentation.
> Of course Ardour wont start with out Jack.
> Any help is greatly appreciated. I am very new to linux.
> Thanks