[PlanetCCRMA] Re: apt-get segfault

Guy Daniel CLOTILDE guy.clotilde@wanadoo.fr
Fri Jan 30 10:57:02 2004

Fernando Pablo Lopez-Lezcano wrote / a écrit:
> What happens if you try a "rpm -q -a --last", does it list all
> packages?

it lists a lot of packages, with SDL_mixer and devel for the last ones:

[root@accent dany]# rpm -q -a --last | more   lun 21 jui 2003 21:28:41 RET
SDL_mixer-1.2.4-5                             lun 26 jan 2004 23:35:54 RET
SDL-devel-1.2.4-5                             lun 26 jan 2004 23:34:11 RET
xfwm4-themes-4.0.3-1                          lun 26 jan 2004 22:57:32 RET
xffm-icons-4.0.3-1                            lun 26 jan 2004 22:57:17 RET
xfdesktop-4.0.3-1                             lun 26 jan 2004 22:57:12 RET
xfce-utils-4.0.3-1                            lun 26 jan 2004 22:57:09 RET
xfce-mcs-plugins-4.0.3-1                      lun 26 jan 2004 22:57:07 RET

> Or some basic package (glibc would be suspect as Axel points out) is
> broken. See if you can check the integrity of a package using rpm:
> "rpm-V glibc", for example. 

Is this normal :
[root@accent dany]# rpm -V glibc
.M...... c /etc/localtime

> If it works you could check all with "rpm
> -V-a". 

what I should be looking for? some lines begin with "missing", but it's normal /usr/lib/qt didn't exist, then I symliked qt-3.0.5.

> You are on 8.0 so it can't be the glibc/kernel/nptl problem. What is
> the history of the system? What did you install recently?

I have tried the evaluation version of vmware and have tried bochs too, but as they were too much slow on my C600, I uninstalled them. I'm thinking of vmware, which said that it can change the system for a better tuning or something like that. When I rpm-ed vmware, vmware let some files in /var/run/vmware and in /usr/lib/vmware.

I keep on investigating...