[PlanetCCRMA] Self-configuring system Was:*Solved* Midisport8x8/s Was:Chasing my tail with ALSA

Michael Sharp mikes@tbc.net
Tue Feb 17 10:06:01 2004

Here is the output from modules.conf The only thing I tried was to put the
add options line first, to see if that would help, but it didn't seem to
affect the system. As far as I can tell, this system I'm on, has only one
active card, the SB512 PCI, and the embedded card on the motherboard has
been disabled in BIOS.


options ide-cd ignore='hdc hdd'
alias usb-controller usb-uhci

# --- Keep modules from being autocleaned ---
add options -k snd-card-0
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.1 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-emu10k1
alias sound-slot-0 snd-emu10k1
# --- END: Generated by ALSACONF, do not edit. ---

-----Original Message-----
From: Fernando Pablo Lopez-Lezcano [mailto:nando@ccrma.Stanford.EDU]
Sent: Tuesday, February 17, 2004 10:26
To: Michael
Cc: Planet List
Subject: Re: [PlanetCCRMA] Self-configuring system Was:*Solved*
Midisport8x8/s Was:Chasing my tail with ALSA

> Today I turn on my system, and guess what? I don't have my Midisport 8x8
> in the ALSA Patchbay anymore. So, I do a little investigating, only to
> find lsmod showing snd-seq-oss, and snd-mixer-oss in the setup again.  I
> wonder what causes this?

Nope, that is not the cause. Both modules should be loaded, they provide
the OSS emulation services. Your modules seem fine except that I don't
see snd-usb-audio, which is the one that would take care (I think) of
your midisport.

What do you currently have in /etc/modules.conf?
Is it configured for two cards?
-- Fernando