[PlanetCCRMA] apt-get fails for planetccrma-core

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Sat Apr 24 10:54:01 2004

> When I try to update the kernel I get an error.  I was able to update
> the alsa rpms, but it still fails.

Update which kernel? Which version? To the one on Planet Edge? (it will
move today to the normal planetcore repository). 

> Any ideas are appreciated.
>  apt-get -o RPM::Install-Options::=--oldpackage install planetccrma-core
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> Since you only requested a single operation it is extremely likely that
> the package is simply not installable and a bug report against
> that package should be filed.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
>   planetccrma-core: Depends: alsa-driver (= 1.0.1-1.cvs.rhfc1.ccrma) but
> 1.0.4-1 is to be installed

It would seem you do not have the Planet Edge repository temporarily
enabled (if that is what you wanted to upgrade to). 

>                     Depends: alsa-lib (= 1.0.1-1.cvs.rhfc1.ccrma) but
> 1.0.4-1.1.fc1.fr is to be installed
>                     Depends: alsa-lib-devel (= 1.0.1-1.cvs.rhfc1.ccrma)
> but 1.0.4-1.1.fc1.fr is to be installed
>                     Depends: alsa-utils (= 1.0.1-1.cvs.rhfc1.ccrma) but
> 1.0.4-1.1.fc1.fr is to be installed
> E: Broken packages

Or you were trying to just install Planet CCRMA for the first time? If
so, I would recomment first disabling Freshrpms from your
/etc/apt/sources.list, the current "official" rpms in Planet CCRMA are a
lower version than Freshrpms and the "planetccrma-core" explicitly
requires the CCRMA ones. 

-- Fernando