[PlanetCCRMA] Problems with the new kernel SOLVED

Sampo Savolainen v2@iki.fi
Sat Sep 27 03:33:01 2003

Hello, now for the good news.

I'm writing this running the new kernel. Everything seems to work fine,
haven't started testing the audio equipment, but that is not the issue
here. The issue is, or was, the kernel not booting due to the root fs
being mounted read-write instead of read-only for fsck operation.

I unpacked the initrd image, mounted it and checked the linuxrc and
found the line mounting the root fs:

  mount -o rw --ro -t ext2 /dev/root /sysroot

Something veeery fishy about this line, so I changed it to

  mount -o ro -t ext2 /dev/root /sysroot

Umounted, gzipped and copied the new image to /boot/ and voilá!

I tested mounting a fs with the --ro parameter, which I've never seen
before in my life and it really worked, it really mounted the fs. Now
what I can't figure out is why didn't it mount the fs read-only for me
and why it mounts read-only for everyone else?

But, anyways. Everything seems to be in order and I have a kick-ass
kernel and ready to do some recording!

Thanks for your great work on these packages Fernando!