[PlanetCCRMA] Package request for SMP kernel sources, and a question about CMUCL worlds for CM/CLM/CMN

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Tue Nov 11 10:58:55 2003

> Please bear with me if I have missed something with Planet --I am 48
> hours new to this distribution. I have been installing chunks of the
> Planet distribution on top of a vanilla RH9 installation, and two things
> have come up:
> 1) It would be nice to have kernel source packages for SMP versions of
> either Planet CCRMA kernel version 2.4.22-6.ll or RedHat kernel version
> 2.4.20-20.1.caps.  I have been trying to install via apt-get as follows:
> #  apt-get install kernel-source#`uname -r`
> Reading Package Lists... Done
> Building Dependency Tree... Done
> E: Couldn't find package kernel-source#2.4.20-20.1.caps.rh90smp

Ommit the smp part, the kernel source package is the same for both the
up and smp kernels. 

> I tried to get SRPMS for the tweaked RH9 kernel,
> (2.4.20-20.1.caps.rh90smp), but still no luck. apt-get didn't like the
> addition of the line:
> rpm-src http://www-ccrma.stanford.edu/planetccrma/apt/
> redhat/7.x/en/i386 planetccrma

The url is a bit old, should be:
rpm-src http://www-ccrma.stanford.edu/planetccrma/apt/
redhat/all/en/i386 planetccrma

> 2) I can get none of the CM/CLM/CMN packages for CMUCL working (although
> they seem to work OK for Clisp).  The error I get is:

What do you see (if anything) before the error?

>  Error in function UNIX::SIGSEGV-HANDLER:  Segmentation Violation at
> #x40008D26.
> Restarts:
>   0: [CONTINUE] Return NIL from load of
> "/usr/lib/cmucl/cmclmcmninit.lisp".
>   1: [ABORT   ] Skip remaining initializations.
> Debug  (type H for help)
> (UNIX::SIGSEGV-HANDLER #<unused-arg>
>                        #<unused-arg>
>                        #.(SYSTEM:INT-SAP #x3FFFE390))
> Source: Error finding source: 
> Error in function DEBUG::GET-FILE-TOP-LEVEL-FORM:  Source file no longer
> exists:
>   target:code/signal.lisp.
> I'm not sure if this is a broken package or some nuance of my
> installation, but I suspect the former.  On this list was a message
> about a similar error (posted Wed Jan 8 18:11:02 2003).  I tried the fix
> given there, but with no success.

I'll take a look at this later. What version do you have installed?
There was something wrong at some point with the installation order of
the packages that I fixed. 

-- Fernando