[PlanetCCRMA] One Big Mess...

Brad Kligerman bkliger@club-internet.fr
Mon Nov 3 13:42:01 2003

...that I've made.

I installed the Planet kernal,alsa etc and got everything working. Then
I installed pd, gem etc... Wanting the latest version of pd, I tried to
install it over the one that is installed via Planet + apt-get... It
didn't work right. I uninstalled pd, gem etc... via synaptic,
reinstalled a newer pd via ./configure, make... and then tried to
install gem via Planet apt-get again. It installed, but I couldn't get
it to work. So I reinstalled pd via Planet + apt-get. etc etc

Somehow, I now have pd installed in 3 places: /usr/local/lib/pd/,
/usr/lib/pd/ and /bin/lib/pd/.

I just tried to install another library (PDP + PiDiPi). It was put in
one of the 3 locations, but I realize that I'm on the road to hell if I
continue like this.

How can I clean up this mess? Should I just get rid of everything and
start over? Can't I just unite everything into one directory? Which one?
And how do I change the paths so that new installations see the good
directory? Can anyone help me on this one?


BTW, when I did have the 2 versions (0.36 & 0.37) of pd running with
gem, I found the one tweaked with Planet much faster. A good sign
despite my heavy handed tinkering.