[PlanetCCRMA] planet ccrma for RedHat 9

Mark Knecht mknecht@controlnet.com
Thu May 8 14:05:02 2003

> > 
> > rpm -e kernel-2.4.20-8
> > error: Failed dependencies:
> >         kernel-drm = 4.3.0 is needed by (installed) XFree86-4.3.0-2
> > 
> > That shouldn't be a problem but Xfree doesn't seem to be 
> working properly, and
> > I believe that its because of that. I tried reinstalling 
> XFree86 but didn't
> > work, maybe I should recompile XFree from the src.rpm? any ideas?  
> Hmmm, no, I should probably tweak the kernel so that it offers the 4.3.0
> drm interface (I don't know what is involved, maybe it is very simple).
> Another day, another kernel :-) 2.4.21-rc1 is out anyway, time to
> update. I tried building it yesterday but there are a couple of
> unresolved symbols, I have to find patches for that. 
> Thanks for the bug report!
> -- Fernando

   I had a problem like with Redhat a while ago, and got a pretty terse 
note from Mike Harris, RH's XF86 guy, saying our 2.4.20 kernel was too 

   In response to that, and for other reasons, I started checking out
Gentoo and ran into the same problem. Their solution, which does work, 
looks like this:

1) Rebuild the kernel with AGPGART as module as well as the radeon driver
as a module (or not at all as will be using drm radeon module)
2) add 'radeon' to you USE flags in /etc/make.conf
3) emerge xfree-drm
4) edit XF86config to enable GLX and DRI, and change the Modes entry
5) reboot and all should work.

   This is now working on my Gentoo setup. I have not tried it under 
Redhat as of yet, but other than how you do steps 2 & 3 I see nothing
distro specific.

   I now get >2000 FPS running glxgears on my Radeon 9000. Not bad
for a $69 card with no fan...