[PlanetCCRMA] planet ccrma for RedHat 9

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Thu May 8 13:26:01 2003

> I had a similar experience when installing the ccrma kernel in RH9 (actually
> my own version compiled without the preemptible feature). I managed to install
> it with -ivh (...and maybe --oldpackage) and it works almost perfect, except
> that now I cannot erase the original kernel (2.4.20-8) because XFree86 depends
> on it:
> rpm -e kernel-2.4.20-8
> error: Failed dependencies:
>         kernel-drm = 4.3.0 is needed by (installed) XFree86-4.3.0-2
> That shouldn't be a problem but Xfree doesn't seem to be working properly, and
> I believe that its because of that. I tried reinstalling XFree86 but didn't
> work, maybe I should recompile XFree from the src.rpm? any ideas?  

Hmmm, no, I should probably tweak the kernel so that it offers the 4.3.0
drm interface (I don't know what is involved, maybe it is very simple).
Another day, another kernel :-) 2.4.21-rc1 is out anyway, time to
update. I tried building it yesterday but there are a couple of
unresolved symbols, I have to find patches for that. 

Thanks for the bug report!
-- Fernando