[PlanetCCRMA] Problem with duplicate packages...

Fernando Pablo Lopez-Lezcano nando@ccrma.Stanford.EDU
Mon Mar 17 20:36:02 2003

> Hi, I think I might have screwed my linux up a bit... There is something
> wrong with my Glib... when I run Synaptic, I get the error-message:
> There are two or more versions of the package "glib-devel" installed in
>  your system, which is a situation APT can't handle cleanly at the
> moment. Please do one of the following: 1) Keep at most one version of
> the package in the system; or 2) If you do want to keep multiple
> versions of that package, look up RPM:Allow-Duplicated in the documentation.
> Error occured while processing glib-devel(UsePackage3)
> Problem with MergeList /var/lib/rpm/Packages
> End of that... so I did a 
> rpm -q glib-devel
> and got 
> glib-devel-1.2.0-1-beta
> glib-devel-1.2.10-8
> so I tried to uninstall both...
> rpm -e glib-devel-1.2.0-1-beta
> and got the return 
> error: package glib-devel-1.2.0-1-beta is not installed
> how do I get rid of that from my packagelist, so that synaptic can
> upgrade to a usable Glib-devel?

It looks like the install of the 1.2.0-1-beta package was not completely
successfull (how did you install it? I'm assuming this is on redhat 8.0
as the default for 8 is 1.2.10-8). 

You could try
  rpm -e glib-devel-1.2.0
(the -1-beta suffix sounds weird to me, should be 1.beta or something
like that). 

Or if that fails you may need to install the 1.2.0 devel package again
(to make sure it is correctly installed) so that you can uninstall it.
It would also help to know why or how you installed the 1.2.0 package. 

-- Fernando