[PlanetCCRMA] Problem with duplicate packages...

franzson@stanford.edu franzson@stanford.edu
Mon Mar 17 20:10:08 2003

Hi, I think I might have screwed my linux up a bit... There is something
wrong with my Glib... when I run Synaptic, I get the error-message:

There are two or more versions of the package "glib-devel" installed in
 your system, which is a situation APT can't handle cleanly at the
moment. Please do one of the following: 1) Keep at most one version of
the package in the system; or 2) If you do want to keep multiple
versions of that package, look up RPM:Allow-Duplicated in the documentation.

Error occured while processing glib-devel(UsePackage3)

Problem with MergeList /var/lib/rpm/Packages

End of that... so I did a 

rpm -q glib-devel

and got 


so I tried to uninstall both...

rpm -e glib-devel-1.2.0-1-beta

and got the return 

error: package glib-devel-1.2.0-1-beta is not installed

how do I get rid of that from my packagelist, so that synaptic can
upgrade to a usable Glib-devel?

David B Franzson