[PlanetCCRMA] alsa-kernel woes

Aaron aamehl@bezeqint.net
Thu Jul 10 08:36:01 2003

Hi all,
I have been installing/uninstalling kernels/alsa for the last month.

I am unable to get alsa working no matter how hard I try.
I am running rh 9.0 with a SB live.
I used a custom kernel so I could use win4lin but I got no alsa, so I
used the planet smp kernel and still no alsa.

I am having some weird problems like to reinstall rh 9.0 after I
accedently did a UVh during a kernel install, I had to disabled the
onboard scsi in my bios, figure it, anyways

I installed the planet smp kernel (not the redhat one)
I tried alsaconf but it didn't find my card.
I updated /etc/modules.conf from the alsa site.
when I tried to remove the oss driver but the command returned:
root@bzq-218-14-208 aamehl]# /sbin/rmmod emu10k1
emu10k1: Device or resource busy
[root@bzq-218-14-208 aamehl]# /sbin/rmmod sound
sound: Device or resource busy
[root@bzq-218-14-208 aamehl]# /sbin/rmmod soundcore
soundcore: Device or resource busy
[root@bzq-218-14-208 aamehl]# /sbin/rmmod ac97_codec
ac97_codec: Device or resource busy
[root@bzq-218-14-208 aamehl]#
so what do I do???