[PlanetCCRMA] RH 8.0 Upgrade

Carr Wilkerson cwilkers@tulane.edu
Fri Jan 24 15:35:02 2003

    I just tried to do an apt-get update and got:

[root@tauzin carrlane]# apt-get update
E: The method driver /usr/lib/apt/methods/http could not be found.

I noticed that I do have /usr/lib/apt/http.

How can I repair this?



-----Original Message-----
From: Fernando Pablo Lopez-Lezcano [mailto:nando@ccrma.Stanford.EDU]
Sent: Sunday, January 05, 2003 9:04 PM
To: Carr Wilkerson
Cc: planetccrma
Subject: Re: [PlanetCCRMA] RH 8.0 Upgrade (fwd)

> I forgot one thing (probably pretty important), when I tried to install
> the apt rpms I got:
> [root@tauzin temp]# rpm -Uvh apt-0.5.4cnc9-fr1.i386.rpm
> error: Failed dependencies:
>         libapt-pkg.so.3.1 is needed by (installed) synaptic-0.16-5
>         apt = 0.3.19cnc55-4.2sp is needed by (installed)
> apt-devel-0.3.19cnc55-4.2sp

I see, you have the old apt and synaptic versions. You have to update
all three rpms at the same time or let apt handle it. You could say
(after downloading things manually - replace the *'s with the complete
version numbers):

  rpm -Uvh apt-0.5.4* apt-devel-0.5.4* synaptic*

  apt-get update
  apt-get install apt apt-devel synaptic

> [root@tauzin temp]# rpm -Uvh apt-devel-0.5.4cnc9-fr1.i386.rpm
> error: Failed dependencies:
>         apt = 0.5.4cnc9-fr1 is needed by apt-devel-0.5.4cnc9-fr1
> One problem may be that I have updated my sources.conf and apt.conf files
> before having been sucessful with upgrading to the RH 8.0 apt.

The sources.list file is common to both versions. The apt.conf file for
apt 0.5.4 is slightly different from the one for the older 0.3.19, but I
think the differences will just trigger some warning messages, no big

-- Fernando