[PlanetCCRMA] ES1969 Solo-1 MIDI port help

Steve Harris S.W.Harris@ecs.soton.ac.uk
Sun Jan 12 03:26:01 2003


I got a "terratec" branded ESS Technology ES1969 Solo-1 Audiodrive (rev
02) yesterday to run some MIDI data into my PC.

lspci guff:

00:0c.0 Multimedia audio controller: ESS Technology ES1969 Solo-1
Audiodrive (rev 02)
        Subsystem: ESS Technology: Unknown device 8898
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (500ns min, 6000ns max)
        Interrupt: pin A routed to IRQ 3
        Region 0: I/O ports at d400 [size=64]
        Region 1: I/O ports at d000 [size=16]
        Region 2: I/O ports at cc00 [size=16]
        Region 3: I/O ports at c800 [size=4]
        Region 4: I/O ports at c400 [size=4]
        Capabilities: [c0] Power Management version 1
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

I think I've got it set up (thanks to alsaconf), modules.conf:

alias char-major-116 snd
alias snd-card-0 snd-es1938
alias snd-card-1 snd-rme9652
options snd-rme9652 snd_enable=1,1 snd_id="Hammerfall" index=1
options snd-rme9652_mem snd_enable=1,1
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-slot-1 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
options snd major=116 cards_limit=2 device_mode=0666
options snd-es1938 index=0

And "64:0 External MIDI 0" appears in kaconnect, but when I wire it up to
AMS I can't see anything in the midi log window, where I think CC's and
such should appear.

I tried running Md2Skini, but that didn't seem to appear in kaconnect so I
couldn't see how to connect it up.

I also tried cat-ing various devs, but I couldn't get anyof them to spew
data when I moved controls.

I have checked that I am sending MIDI data. I've a suspicion that my
soundcard midi cable may be broken (it about 10 years old, and hasn't been
used for a year), but I'd like to make sure theres nothing obviously wrong
before I buy a new one.

- Steve