[PlanetCCRMA] alsa driver not running, somehow involves alsactl and snd_ctl_open

Richard Benedict richard.benedict@sympatico.ca
Sun Jan 5 12:45:02 2003


I'm new to the list.  Hope everybody's having a happy new year so far. 
I use Red Hat 8.0, and I'm trying to get my soundcard up and running
(Delta Audiophile 2496 using ice1712), but alsa isn't letting me do so. 
This is the modified /etc/modules.conf file after running alsaconf.

alias parport_lowlevel parport_pc
alias eth0 8139too
alias usb-controller usb-uhci
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 0.9.0 ---
alias char-major-116 snd
alias snd-card-0 snd-ice1712
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
options snd major=116 cards_limit=1 device_mode=0666
options snd-ice1712 index=0
# --- END: Generated by ALSACONF, do not edit. ---

This is what happened when I ran alsaconf:

[root@localhost richard]# /usr/sbin/alsaconf
/usr/sbin/alsaconf: line 111: modinfo: command not found

...(start-up screen)...

 ┌────────────────────────── Soundcard Selection...

 │          Choose a soundcard to

 │ │          ice1712  IC Ensemble Inc ICE1712 [Envy24] (rev
02)          │ │
 │ │          legacy   Probe legacy ISA (non-PnP)
chips                   │ │


 <Cancel>                       │
              │                                                │
              │ Configuring snd-ice1712                        │
              │ Do you want to modify /etc/modules.conf?       │
              │                                                │
              │             < Yes >       < No  >              │

Loading driver..
Starting sound driver snd-ice1712                          [  OK  ]
Starting sequencer driver snd-seq-midi                     [  OK  ]
Restoring sound driver settings /usr/sbin/alsactl: load_state:1123: No
found...                                                          │
         │                                                 [FAILED] │
Setting default volumes..r snd-ice1712 is configured.               │
         │                   ALSA  CONFIGURATOR                     │
 Now ALSA is ready to use.                                          │

Then I ran alsamixer and gnome-alsamixer:

[richard@localhost richard]$ alsamixer

alsamixer: function snd_ctl_open failed for default: No such file or
[richard@localhost richard]$ gnome-alsamixer

(gnome-alsamixer:3345): GLib-GObject-WARNING **: invalid cast from
(NULL) pointer to `GamMixer'

I'm somewhat a newbie.  What does this mean and how do I fix it?

Richard Benedict

Toronto, Canada