[PlanetCCRMA] problem installing cmucl-cm-clm-cmn

Wes Shull wes@kuoi.asui.uidaho.edu
Sun Dec 21 14:13:01 2003

I've gotten this every time I've tried to install cmucl-cm-clm-cmn since I 
upgraded to fc1 and the planet ccrma fc1 packages:

Uncompressing lisp core...
Rebuilding clm foreign function interface...
/var/tmp/rpm-tmp.88773: line 10:  4291 Segmentation fault      /usr/bin/lisp 
-core /usr/lib/cmucl/cm-clm-cmn.core -eval "(clm::rebuild-ffi)(sys::quit)" 

Actually, for all I know it did the same thing on my system under rh90 but I 
didn't notice; I haven't ever used this package, I just installed everything.

I've tried rpm -ev --nodeps the whole chain of lisp tools 
(common-lisp-controller, cmucl, c*-source, and cmucl-cm-clm-cmn), apt-get 
clean, apt-get update, apt-get -f dist-upgrade, and it *still* does the same 
thing, so I don't think it's a dependency or version issue.  Maybe something 
is getting over-optimized by gcc 3.3.2 and needs to rebuilt under gcc32?

My system is an Athlon XP 1700+ on kernel 2.4.23-1.ll.rhfc1.ccrma (previously 
was using 2.4.22-9.23rc3.ll.rhfc1.ccrma), all updates from fc1 and planet 
ccrma up to date.